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About the Data Interoperability extension tutorial

The Data Interoperability extension tutorial introduces you to the tools and functionality that are available in
ArcGIS when the extension is enabled. It is divided into three sections that guide you through direct-read
formats and interoperability connections, quick conversion tools, and the fundamentals of transforming data
using FME Workbench.

The exercises within each section demonstrate concepts and methods sequentially and therefore should be
completed in the order they are presented. They are designed to allow you to work at your own pace without
additional assistance using ESRI ArcTutor sample data.

You will need about 30—-40 minutes of focused time to complete all the exercises.

This tutorial assumes you have installed the ESRI ArcTutor data at C:\arcgis\ArcTutor\Data Interoperability.
If not, make the appropriate path changes throughout this tutorial. Ask your system administrator for the
correct path to the tutorial data if you do not find it at the default installation path.

* In Exercise 1a: Using direct-read formats, you work directly with a Mapinfo TAB dataset in ArcMap.

« In Exercise 1b: Adding interoperability connections, you create and work with an interoperability
connection for Intergraph Modular GIS Environment (MGE) data.

* In Exercise 2a: Importing data with the Quick Import tool, you import Geography Markup Language
(GML) zoning data using the Quick Import tool.

* In Exercise 2b: Exporting data with the Quick Export tool, you export geodatabase zoning data to a
Maplinfo TAB dataset using the Quick Export tool.

* In Exercise 2c: Automating quick conversion tools with ModelBuilder, you create a model that
imports GML zoning data, aggregates features based on specific attributes, and exports the results
to GML and Mapinfo TAB datasets.

» In Exercise 3a: Getting started with spatial ETL, you create a simple spatial ETL tool that reads
Intergraph Modular GIS Environment (MGE) parcel data and loads it into a geodatabase.

* In Exercise 3b: Transforming data and using Visualizer, you learn the fundamentals of using FME
transformers by adding them to the spatial ETL tool you created in "Getting started with spatial ETL."

* In Exercise 3c: Using source attributes to separate data, you learn how to use spatial ETL to
categorize data and generate sets of features with common values.

Copyright © 1995-2012 Esri. All rights reserved.



Data Interoperability Extension Tutorial

Exercise 1a: Using direct-read formats

Direct-read formats are used directly from the Catalog tree as read-only Complejidad:

Principiante
datasets. When you add them to ArcMap, ArcScene, or ArcGlobe, all Requisitos de datos: .
standard map functions are enabled, including attribute tables and labeling Configuracion de datos de tutorial de
functions. Ruta de datos:

C:\arcgis\ArcTutor\Data Interoperability\
Using a direct-read feature class in ArcMap is similar to working with other Objetivo: _ _

. Learn how to work with nonnative

geodatabase feature classes. You can snap to geometry, substitute datasets in ArcMap when the Data

. . . . Interoperability extension is enabled.
symbology, query attributes, and use it with all geoprocessing tools that

accept feature classes or layers as input.

This exercise introduces you to direct-read formats using Maplnfo TAB data; other formats supported by the
Data Interoperability extension can be used in the same way.

Requisito previo:
The Data Interoperability extension must be enabled.

Pasos:
1. Start ArcMap.
2. Click the Catalog Window button (3] on the Standard toolbar.

3. Type C:\arcgis\ArcTutor\Data Interoperability\ inthe Location text box and
press ENTER.
The location is added to the Catalog tree under the Folders Connections heading.

4. Click the subdivisions.tab dataset and drag it into your map.
ArcGIS uses spatial indexes to quickly locate features in feature classes. Notice that ArcGIS
indexes the dataset the first time you add it to ArcMap and displays a status window. The
display duration of the window depends on the size of the dataset; the window may be
displayed only for a few seconds for small datasets.

5. Right-click the subdivisions Line feature layer and click Open Attribute Table.
The feature layer contains no data. Repeat this step for other feature layers and observe that
only the Polygon feature layer contains data.

6. Right-click the folder in the table of contents and click Remove.
The dataset is removed from ArcMap.

Unlike a native ESRI dataset, when you connect to a MapInfo TAB dataset for the first time, it generates a

feature class entry for all geometries supported by the format; other nonnative formats produce similar
results. The next section will show you how to purge empty feature classes from the dataset.

To purge empty feature classes from the dataset, refresh the dataset in the Catalog tree.

Pasos:
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Click the subdivisions.tab dataset in the Catalog window.
Press E5 to refresh the data, or right-click the dataset and click Refresh.

Expand the dataset in the Catalog tree.
Only the subdivision Polygon feature layer is displayed.

Explore the dataset in ArcMap and the Catalog window to gain insight about working with nonnative data
formats when the Data Interoperability extension is enabled.

Pasos:
1.

Right-click the subdivision Polygon feature class in the Catalog tree, and click Item Properties
from the shortcut menu.

Click the Description tab and explore the metadata.
Drag the subdivision Polygon feature class into ArcMap.

Click the Identify button and select a feature to view the attributes.

This completes the exercise.

Continue to the next exercise: Exercise 1b: Adding interoperability connections.

Copyright © 1995-2012 Esri. All rights reserved.
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Exercise 1b: Adding interoperability connections

Interoperability connections can be used to aggregate files, perform Complejidad:
. . . . Principiante

translations on the fly, define a coordinate system, and store format-specific Requisitos de datos: .
parameters such as database connections and passwords. All Configuracion de datos de tutorial de
interoperability connections are saved in the Interoperability Connections Ruta de datos:

C:\arcgis\ArcTutor\Data Interoperability\
folder. Obietivo:

jetivo:

Create an interoperability connection.

In this exercise, you create an interoperability connection for Intergraph
Modular GIS Environment (MGE) parcel data.

The MGE format uses standard MicroStation DGN files to store and edit the graphic elements of geographic
data. The nongraphic elements, such as feature attributes, are stored in external database tables and linked to
the graphic elements via pairs of entity and mslink numbers.

Using the Add Interoperability Connection dialog box, you perform the following tasks:
» Choose the FME reader and specify the data source.

+ Specify the reader parameters for the external database.
» Define a coordinate system.
» Create the connection.

After creating the connection, you add the dataset to ArcMap, change symbology, and select features by
attributes.

Requisito previo:
The Data Interoperability extension must be enabled.

Pasos:
1. Start ArcMap.
2. Click the Catalog Window button [3] on the Standard toolbar.

3. Expand the Interoperability Connections folder.

Catalog @
oD@ E-lalE
Location: @ Interoperability Connections -

+ ] Home - MyData\MXD

# 3 Folder Connections

¥ @ Toolboxes

# 3 Database Servers

+ 5l Database Connections

+ {3 GIS Servers

S Interoperability Connections

y Add Interoperability Connection
’ p‘n.-ﬁﬁ_‘w -.-_A--tg"“‘i -.rx_‘_..“

4. Double-click Add Interoperability Connection.
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The Interoperability Connection dialog box opens.

Choosing the FME reader

Pasos:

1. Click the Format browse button.
The FME Reader Gallery dialog box opens.

&) FME Reader Gallery -
Description : Short Name Extensions Type Cn!
Intergraph MGE MGE .cad,.dgn File

Search Custom Formats EE’
mge [ New... ] [ Import... ] Edit Delete... OK Can
. 3

2. Type mge in the Search text box.
3. Click the row listing the Intergraph MGE format.

4. Click OK.
The FME Reader Gallery dialog box closes and the Format text box is populated with the
format description.

Specifying the data source

Pasos:

1. Click the Dataset browse button.
The Select File dialog box opens.

2. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\parcels folder.
3. Click the File Type arrow and choose All Files (*.).

The files with a .par file extension are displayed in the dialog box.

|- Nota: The MicroStation DGN format permits files to be saved without a
file extension or with an extension of any length. As a result, it is
not uncommon for DGN files to be saved with an extension that
describes the contents. This tutorial uses the .par extension to
identify them as parcel drawings.

4. Click the parcel_K24.par file and click Open.
The Dataset text box is populated with the path and file name.

Specifying the reader parameters

Specify the external database that contains the attribute tables.

Pasos:
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1. Click the Parameters button.
The Intergraph MGE Parameters dialog box opens.
[ B Intergraph MGE Parameters [ilér
Database Connection "
Databaze Type: [MDB v]
Access MDB File: zrability\parcels\parcel_attrs.mdb™ []
ata Source; pused =
W viniey oo O Sl
2. Click the Database Type arrow and choose MDB.
3. Click the Access MDB File browse button.
4. Navigate to C:\arcgis\ArcTutor\Data Interoperability\parcels\parcel_attrs.mdb and click
Open.
5. Click OK.
The Intergraph MGE Parameters dialog box closes.
Pasos:
1. Click the Coordinate System browse button.
The Spatial Reference Properties dialog box opens.
2. Click Select.
3. Double-click the Projected Coordinate Systems folder, double-click the State Plane folder,
double-click the NAD 1983 (US Feet) folder, choose NAD 1983 StatePlane Texas Central
FIPS 4203 (Feet).prj, then click Add.
4. Click OK.
The Spatial Reference Properties dialog box closes.
[ Q Interoperability Connection @lé] |
Reader

Format:

Dataset: s\ArcTutor\Data Interoperability\parcels\parcel _K24.par™ E]

Coordinate System: _Central_FIPS_4203_Feet [Z]
&) Lo )

Intergraph MGE - E]

A

Pasos:
1.

Click OK in the Interoperability Connection dialog box.
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The Interoperability Connection dialog box closes, and an interoperability connection
named Connection (1)—parcel_K24 MGE is added to the Interoperability Connections
folder.

2. Right-click the dataset, click Rename, then rename it to parcel K24.

3. Expand the parcel K24 dataset in the Catalog tree.
The dataset displays several feature classes that are potentially empty and not needed.

4. Click the parcel K24 dataset and press E5 to purge any empty feature classes.

5. Expand the parcel K24 dataset and confirm your results.
The dataset contains only two feature classes.

Add the interoperability connection for the MGE parcel K24 dataset to ArcMap. Also add the Maplinfo
subdivisions.tab dataset, and the Maplinfo flood plains.mif dataset.

Pasos:
1. Drag the parcel K24 dataset into ArcMap.

2. Inthe Catalog window, type C:\arcgis\ArcTutor\Data Interoperability inthe
Location text box and press ENTER.
The location is added to the Catalog tree under the Folders Connection heading.

3. Expand the flood_plains.mif dataset and drag the flood_plains Polygon feature class into
ArcMap.

4. Expand the subdivisions.tab dataset and drag the subdivisions Polygon feature class into
ArcMap.

Assign a unique symbol for each date a subdivision was added to the survey. Use the ADD_DATE field.
Also, set MapTips to display the contents of the SUBDIVISION field when pausing the pointer over a
subdivision.

Pasos:

1. Right-click the subdivisions Polygon layer and click Properties.
The Layer Properties dialog box opens.

Click the Display tab.

In the Display Expression box, click the Fields arrow and choose the SUBDIVISION field.
Check the box Show MapTips using the display expression.

Click the Symbology tab.

Click Categories and click Unique values.

Click the Value Field arrow and choose the ADD_DATE field.

Click the Add all Values button.
A unique symbol is generated for each unique value in the field.

©® N o 0 M W N
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10.
11.

Click OK.
The Layer Properties dialog box closes.

Right-click the subdivisions Polygon layer in the table of contents and click Zoom to Layer.

Pause the pointer over the subdivisions to see the names displayed as MapTips.

Select by attributes

Search for Gaston Park and zoom to it.

Pasos:
1.

7.

On the main menu, click Selection > Select By Attributes .
The Select by Attributes dialog box opens.

Click the Layer arrow and choose the subdivisions Polygon feature layer.

Double-click the SUBDIVISION field.
The field name is added to the expression box.

Click the Like button and press the SPACEBAR once to add a space after the word.

Type 'GAS%' to complete the SQL statement.
The completed expression should read "SUBDIVISION" LIKE 'GASS%'.

Click the Apply button.
The selected features are highlighted in the map.

Table Of Contents 1 x

TRCR A=
B = Layers
= LOT_POINTS Point
L]

= o LOT_LINES Line

= subdivisions Polygon

[ <all other values>
ADD_DATE

(|
[ 20011207
120011226
[] 20020212
[]20020424
[]20020626
[] 20020821
[]20020918
[] 20030516
[120030826
[]20031124
[] 20031222
[] 20040111
[120040316
[] 20040506

= flood_plains Polygon

'-Ar —AI?I‘-' —— , >

Click the OK button.
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The Select by Attributes dialog box closes.

8. On the main menu, click Selection > Zoom To Select Features .

9. Pause the pointer over the selected feature to display the name GASTON PARK as a MapTip.

This completes the exercise.

Continue to the next exercise: Exercise 2a: Importing data with the Quick Import tool.
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Exercise 2a: Importing data with the Quick Import tool

The Quick Import tool converts any data source supported by the Data
Interoperability extension and loads it into a geodatabase using a simple
one-to-one translation. This tool is ideal for importing nonnative data when

your workflow does not require feature geometry or schema to be modified.

In this exercise, you import Geography Markup Language (GML) zoning
data.

Using the Quick Import dialog box, you perform the following tasks:
» Choose the FME reader and specify the data source.

» Accept the default reader parameters.
» Accept the coordinate system defined by the data source.
+ Specify the destination staging geodatabase.

» Import the data.

After importing the data, you add the dataset to ArcMap to verify your results.

Open the tool and specify input
Requisito previo:
The Data Interoperability extension must be enabled.
Pasos:

1. Start ArcMap.

Click the Catalog Window button 3 on the Standard toolbar.

Complejidad:
Principiante

Requisitos de datos:
Configuracion de datos de tutorial de
ArcGIS

Ruta de datos:
C:\arcgis\ArcTutor\Data Interoperability\
Objetivo:
Import GML data using the Quick Import
tool.

2
3. Find and open the Quick Import tool using the Search window [l
4

Click the Input Dataset browse button.
The Specify Data Source dialog box opens.

Choosing the FME reader

Pasos:

1. Click the Format browse button.
The FME Reader Gallery dialog box opens.

) FME Reader Gallery

-

Description Short Mame Extensions
BC MoF Electronic Submission Fr..  ESF .gml, xml,.gz
CityGML CITYGML .gml, xml,.gz
Dutch TOP10 GML TOP10 .gml,xml,.gz
GML (Geography Markup Langua...
Search Custom Formats

gml New... ] ’ Import... Edit Delete...

File .
File -
File

Copyright © 1995-2012 Esri. All rights reserved.
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2.
3.

Type gml in the Search text box.

Click the row listing Geography Markup Language (GML) and click OK.
The FME Reader Gallery dialog box closes.

'Q Specify Data Source l D |
Reader
Format:  GML (Geography Markup Language) - EI
Dataset: arcgis\ArcTutor\Data Interoperability \zoning\zoning. gml™ El Ell
Coordinate System: FRead from source El

Help QK. | | Cancel |

e

Pasos:
1.

Click the Dataset browse button.
The Select File dialog box opens.

Navigate to the C:\arcgis\ArcTutor\Data Interoperability\zoning folder.
Click the zoning.gml dataset and click Open.

The Dataset text box is populated with the path and file name.

/i, Precaucion: Some file extensions can be associated with more than one format. It is
good practice to visually confirm that the format and file extension are
correctly matched before closing the dialog box.

Click OK.
The Specify Data Source dialog box closes.

The Quick Import tool creates a geodatabase as output. The output staging geodatabase can be used
directly or for further processing.

Pasos:
1.

Click the Output Staging Geodatabase browse button, navigate to the
C:\arcgis\ArcTutor\Data Interoperability\zoning folder, type zoning in the Name text box, then
click Save.

The Output Staging Geodatabase text box is populated with the path and name.

Click OK.

The tool executes the conversion in the background. A progress bar at the bottom of your map
displays the name of the tool. When the tool is finished, a pop-up notification appears in the
system tray. You can examine the details of the conversion in the Results window.

Copyright © 1995-2012 Esri. All rights reserved. 13
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Add the data to ArcMap

Pasos:

1. Type C:\arcgis\ArcTutor\Data Interoperability\zoning\zoning.gdb inthe
Location text box and press ENTER.
The location is added to the Catalog tree under the Folders Connection heading.

Catalog =
e @ E-le

Location: L# zoning.gdb -

= £ CharcgishArcTutor\Data Interoperability =
£ birds_eggs
£ major_roads
£ parcels
= E zoning
= L3 zoning.gdb

| [E) zonin

2. Drag the zoning feature class into ArcMap and verify your results.

Table Of Contents 1 x
2G8|H
=l = layers
= zoning
O

This completes the exercise.

Continue to the next exercise: Exercise 2b: Exporting data with the Quick Export tool.

Copyright © 1995-2012 Esri. All rights reserved.
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Exercise 2b: Exporting data with the Quick Export tool

The Quick Export tool converts geodatabase feature classes or feature Complejidad:

- Principiante
layers to any external dataset supported by the Data Interoperability Requisitos de datos: _
extension using a simple one-to-one translation. This tool is ideal for Configuracion de datos de tutorial de
exporting data to nonnative datasets when your workflow does not require Ruta de datos:

C:\arcgis\ArcTutor\Data Interoperability\

Objetivo:
. . . Export geodatabase data to a MapInfo
In this exercise, you export geodatabase zoning data to a MapInfo TAB TAB dataset using the Quick Export tool.

dataset.

feature geometry or schema to be modified.

Using the Quick Export dialog box, you perform the following tasks:
» Specify the geodatabase data source.

» Choose the FME writer and specify the data destination.
» Accept the default writer parameters.
» Accept the coordinate system defined by the data source.
+ Export the data.
After exporting the data, you add the dataset to ArcMap to verify your results.

Requisito previo:
The Data Interoperability extension must be enabled.

Before starting this exercise, you must have completed the previous exercise, Exercise 2a: Importing data
with the Quick Import tool.

Pasos:

1. Start ArcMap.

2. Click the Catalog Window button 5 on the Standard toolbar.
3. Find and open the Quick Export tool using the Search window Fl.
4

Type C:\arcgis\ArcTutor\Data Interoperability\zoning\zoning.gdb inthe
Location text box and press ENTER.
The location is added to the Catalog tree under the Folders Connection heading.

Catalog @
¢.vq>%@d;|5;;;v| |LEE

Location: L zoning.gdb -

= £ Charcgis\ArcTutor\Data Interoperability  »
# £ birds_eqgs
# B major_roads
+ ] parcels
= B3 zaning
SR | zoning.gdb

2 ‘Q E]zomng .-1%"_“*..\\-/‘

5. Drag the zoning feature class into the Input Features text box.

Copyright © 1995-2012 Esri. All rights reserved.
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Specify the output and run the tool

Pasos:

1. Click the Output Dataset browse button.
The Specify Data Destination dialog box opens.

Choosing the FME writer

Pasos:

1. Click the Format browse button.
The FME Writer Gallery dialog box opens.

Q) FME Writer Gallery

Description = Short Mame Extensions Type CL/

ESRI Geodatabase (4rcSDE) GEODATABASE SDE Database

ESRI Geodatabase (File-based) GEODATABASE_FILE .gdb Geodatabase
ESRI Geodatabase (MDE) GEODATABASE_MDE mdb File
Maplnfo TAB (MITAB)

Search Custom Formats

tab MNew... ] l Impart... Edit Delete... i Ok I

2. Type tab in the Search text box.

3. Click the row listing Maplnfo TAB (MITAB) and click OK.
The FME Writer Gallery dialog box closes.

Specifying the data destination and running the tool

Pasos:

1. Click the Dataset browse button.
The Select Folder dialog box opens.

2. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\zoning folder and click Open.
The Select Folder dialog box closes and the Dataset text box is populated with the path. By
default, the Mapinfo TAB writer uses the input feature class name.

s ~
Q Specify Data Destination |@733|
Writer
Format:  MapInfo TAB (MITAE) v [
Dataset: "C:\arcgis\ArcTutor\Data Interoperabilityzoning™ B
Coordinate System: Same as source B
o] (o ]
h

3. Click OK.
The Specify Data Destination dialog box closes.
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4. Click OK.
The tool executes the conversion in the background. A progress bar at the bottom of your
map displays the name of the tool. When the tool is finished, a pop-up notification appears in
the system tray. You can examine the details of the conversion in the Results window.

Add the data to ArcMap

Pasos:
1. Click the zoning folder and press E5 to refresh the contents.
2. Expand the new zoning.tab dataset in the Catalog window.

3. Drag the zoning Polygon feature class into ArcMap and verify your results.

Table Of Contents 1 x

2G8HE
=l = Layers
= zoning Polygon
(|

This completes the exercise.

Continue to the next exercise: Exercise 2c: Automating quick conversion tools with ModelBuilder.

Copyright © 1995-2012 Esri. All rights reserved.

17



Data Interoperability Extension Tutorial

Exercise 2c: Automating quick conversion tools with
ModelBuilder

The Data Interoperability quick conversion tools can be used in ModelBuilder  complejidad:

. . Intermedio
and connected to other geoprocessing tools to automate conversion Requlsitos de datos:
workflows Configuracién de datos de tutorial de
’ ArcGIS
i i i H . Ruta de datos:
In this exercise, you build a model that performs the following tasks: Charcgio\ArcTutor\Data Interoperability

* Imports geodatabase zoning data Objetivo:
Automate the execution of quick

conversion tools using ModelBuilder.

» Aggregates the polygons and removes grid tiles

» Exports the results to GML and Mapinfo TAB formats

Requisito previo:
The Data Interoperability extension must be enabled.

Pasos:
1. Start ArcMap.
2. Click the Catalog Window button (3] on the Standard toolbar.

3. Type C:\arcgis\ArcTutor\Data Interoperability\zoning\ inthe Location text

box and press ENTER.
The location is added to the Catalog tree under the Folders Connection heading.

Catalog @

e @ E-lal s

Location: [ ZOning -
=1 £ Data Interoperability -

+ 5 birds_eggs

# & major_roads

+ ] parcels

= [ zoning
= L zoning.gdb
= a zoning.thx

Tl %E“Mfy il =

4. Right-click the zoning folder and click New > Toolbox .
5. Right-click the toolbox, click Rename, then name it zoning.
6. Right-click the zoning toolbox and click New > Model .

ModelBuilder opens.

iy Sugerencia: By default, the model is named Model. You can rename it by right-
clicking it in the Catalog window and clicking Rename from the shortcut
menu.

Copyright © 1995-2012 Esri. All rights reserved. 18
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Add the Quick Import tool

Pasos:

1. Find the Quick Import tool using the Search window ] and drag it onto the ModelBuilder

canvas.
2. Double-click Quick Import.

3. Click the Input Dataset browse button.
The Specify Data Source dialog box opens.

Choosing the FME reader

Pasos:

1. Click the Format browse button.

The FME Reader Gallery dialog box opens.

) FME Reader Gallery

Description Short Mame
BC MoF Electronic Submission Fr..  ESF
CityGML CITYGML
Dutch TOP10 GML TOP10
GML (Geography Markup Langua... GML
Search Custom Formats
aml New... ] [ Import. .. Edit

Extensions

.gml,xml,.gz
.gml,xml,.gz

.gml, xml,.gz

.gml, xml,.gz

Delete...

2. Type gml in the Search text box.

3. Click the row listing Geography Markup Language (GML) and click OK.
The FME Reader Gallery dialog box closes.

Specifying the data source

Pasos:

1. Click the Dataset browse button.
The Select File dialog box opens.

2. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\zoning folder.

3. Click the zoning.gml dataset and click Open.
The Dataset text box is populated with the path and file name.

/i, Precaucion: Some file extensions can be associated with more than one format. It is
good practice to visually confirm that the format and file extension are
correctly matched before closing the dialog box.

4. Click OK.

The Specify Data Source dialog box closes.

Copyright © 1995-2012 Esri. All rights reserved.
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Pasos:

1. Click the Output Staging Geodatabase browse button, navigate to the
C:\arcgis\ArcTutor\Data Interoperability\zoning folder, type zoning2 in the Name text box,
then click Save.

The Output Staging Geodatabase text box is populated with the path and name. In the
following section, you connect this output as input to the Select Data tool.

2. Click OK.
The Quick Import dialog box closes and displays the tool in a ready-to-run state.

ﬂ\

Quick Import zoning2.gdb

Use the Select Data tool to select the zoning feature class contained in the zoning2.gdb geodatabase.

Pasos:

1. Find the Select Data (ModelBuilder) tool using the Search window Gl and drag it onto the
ModelBuilder canvas.

2. Click the Connect button on the toolbar.

3. Click zoning2.gdb, click Select Data, then click Input Data Element on the shortcut menu.
The output geodatabase zoning2.gdb is connected as input to the Select Data tool.

J R,
Quick Import zoning2_gdb
/4
s .
Output data
Select Data element
Input Data Element
Environments >
Precondition

4. Double-click Select Data and confirm that the Child Data Element text box is set to zoning.

The child data element is the feature class contained in the zoning2.gdb output geodatabase
that will be used as input to the Dissolve tool.

5. Click OK.
This closes the Select Data dialog box.
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Pasos:

1. Find the Dissolve tool using the Search window gl and drag it onto the ModelBuilder canvas.
2. Click the Connect button on the toolbar.

3. Click Output data element, click Dissolve, then click Input Features from the shortcut menu.
The output data element is connected as input to the Dissolve tool.

J\ i,

Quick Import zoning2_gdb

Qutput data
element

Output

Diss| Input Features |l\aalure
Class
Environments »
Precondition

4. Double-click Dissolve to open the dialog box.

5. Click the Output Feature Class browse button.
The Output Feature Class dialog box opens.

6. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\zoning folder, type
zoning dissolve in the Name text box, then click Save.
The Output Feature Class dialog box closes and the Output Feature Class text box is
populated with the path and file name. By default, the tool adds the (.shp) file extension.

[ !‘% Dissolve
Input Features n Dis SOWEI
|Output data element ﬂ '
Output Feature Class Aggregates fai.

C:\arcgis\ArcTutor\Data Interoperability \zoning\zoning_dissalve.shp on specifie d3
Dissolve_Field(s) (optional) T
[ gml_geometry_property E?:S”;h::ﬂrfu?
[ gml_id
[ submission_date %
type
N Y SRR e e PR

7. Check the type check box in the Dissolve_Field(s) list.
Features with the same values for checked fields are aggregated (dissolved) into a single
feature. The dissolve fields are written to the output feature class.

8. Click OK.
The Dissolve dialog box closes.
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9.

Click Model > Save.

Run the model

The model generates a shapefile. During execution, the status window appears and displays a processing

log.
Pasos:

1.

Click the Run button .
All the tools in a ready-to-run state are executed.

Click Close on the status message when the model finishes executing.

On the ModelBuilder canvas, right-click zoning_dissolve.shp and click Add To Display from
the shortcut menu.
The results of the tool are displayed in ArcMap.

Table Of Contents 1 x

EEELE
B = Layers

=i ol
(|

Table

ERAL AL L i

zoning_dissolve
FID | Shape type

L)
" 4
L
-
3 0 | Polygon *
Polygon | AW
2 | Polygon | CH
'A-.J '-.‘ -E-'&EEE_ CH-V-, \J*-m\‘u‘\rm\

Right-click the zoning_dissolve feature layer in the table of contents and click Open Attribute
Table on the shortcut menu.
The features with the same type field values are aggregated.

Close the attribute table.

Right-click the original zoning feature class in the Catalog window, click Iltem Properties on
the shortcut menu, then click the Preview tab.
Compare your results and notice that the Dissolve tool removed the grid tiles.

On the canvas, right-click zoning_dissolve.shp and click Add To Display from the shortcut
menu.
The results are removed from ArcMap.

Add the Quick Export tool

Add the Quick Export tool to generate a Geography Markup Language (GML) dataset.

Pasos:
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Find the Quick Export tool using the Search window 5l and drag it onto the ModelBuilder

canvas.

Right-click Output Dataset, click Rename from the shortcut menu, then type Output GML

Dataset.

Click the Connect button on the toolbar.

Click zoning_dis

solve.shp, click Quick Export, then click Input Layer on the shortcut menu.

The output zoning_dissolve.shp file is connected to the Quick Export input.

Pasos:
1.

=

Quick Import

“ N
. Output
Select Data Quick Export GML
| Input Layer | Dataset
-~ @@~
Environments  »
.{\}. Precondition
Dissolve
-~ @~
5. Double-click Quick Export.
6. Click the Output Dataset browse button.
The Specify Data Destination dialog box opens.
Choosing the FME writer
Click the Format browse button.
The FME Writer Gallery dialog box opens.
[ Q) FME Writer Gallery

Description . Short Mame Extensions Type Coord.
CityGML CITYGML .gml, xml,.gz File
GML (Geography Markup Language) .gml, xml,.gz
GML 5F-0 (Geography Markup Langua.. GMLSF .gml, xml,.gz File
XML (Extensible Markup Language) XML xml,.gml,.gz File

Search
aml

Custom Formats

/| I J 4
New... Import... Edit Delete... oK Canci

2. Type gml in the Search text box.

3. Click the row listing Geography Markup Language (GML) and click OK.
The FME Writer Gallery dialog box closes.

Copyright © 1995-2012 Esri. All rights reserved.

23



Data Interoperability Extension Tutorial

Pasos:

1. Click the Dataset browse button.
The Select File dialog box opens.

2. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\zoning folder, type zoning output
in the File name text box, then click Save.
The Select File dialog box closes and the Dataset text box is populated with the path and

file name.
Q Speafy Data Destination |@7X|
Writer
Format:  GML (Geography Markup Language) - E

Dataset: gisVArcTutor\Data Interoperability\zoning \zoning_output, gml™ B

Parameters... Coordinate System: Same as source

(o]

CK

=

3. Click OK.

The Specify Data Destination dialog box closes.

Add another instance of the Quick Export tool to generate a Mapinfo TAB dataset.

Pasos:

1. Find the Quick Export tool using the Search window G and drag it onto the ModelBuilder

canvas.

2. Right-click Output Dataset, click Rename from the shortcut menu, and type Output TAB

Dataset.

3. Click the Connect button on the toolbar.

4. Click zoning_dissolve.shp, click Quick Export (2), then click Input Layer on the shortcut

menu.

The output zoning_dissolve.shp is connected to the Quick Export (2) input.
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2

Quick Import

S
Quick Export

“

Select Data

N

Quick (2 TAB
uick Export (2) Dataset
| Input Layer |
|
Envirenments  »
Precondition
5. Double-click Quick Export (2).
6. Click the Output Dataset browse button.
The Specify Data Destination dialog box opens.
Choosing the FME writer
Pasos:
1. Click the Format browse button.
The FME Writer Gallery dialog box opens.
rQ FME Writer Gallery
Description = Short Mame Extensions Type Co{
ESRI Geodatabase (4rcSDE) GEODATABASE SDE Database
ESRI Geodatabase (File-based) GEODATABASE_FILE .gdb Geodatabase

File
File/Directory

mdb

GEODATABASE MDB

ESRI Geodatabase (MDE)
Maplnfe TAB (MITAB)

Search Custom Formats

tab New... ] l Import... l | Edit | | Delete... | I =
7

2. Type tab in the Search text box.

3. Click the row listing MapInfo TAB (MITAB) and click OK.
The FME Writer Gallery dialog box closes.

Specifying the data destination

Pasos:

1. Click the Dataset browse button.
The Select Folder dialog box opens.

2. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\zoning folder and click Open.
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The Select Folder dialog box closes and the Dataset text box is populated with the path. By
default, the Maplinfo TAB writer uses the input feature class name.

Q Specify Data Destination |@—X§P
Writer
Format:  MapInfo TAE (MITAE) * [
Dataset: "C:\arcgis\ArcTutor'\Data Interoperabilityzoning™ D
Parameters... Coordinate System: Same as source D
Help QK. ‘ l Cancel ‘
y

3. Click OK.
The Specify Data Destination dialog box closes.

4. Click Model > Save.

Pasos:

1. On the main menu, click Model > Run Entire Model.
The model creates a zoning_dissolve.tab dataset and a zoning_output.gml dataset. During
execution, the Model status window appears and displays a processing log.

2. Click Close on the status window when the model is finished.
3. Inthe Catalog window, navigate to the C:\arcgis\ArcTutor\Data Interoperability\zoning folder.

4. Expand the zoning_dissolve.tab dataset, right-click the zoning Polygon feature class, then click
Item Description on the shortcut menu.
Preview the image and explore the metadata.

5. Expand the zoning_output.gml dataset, right-click the zoning_dissolve Polygon feature class,
then click Item Description on the shortcut menu.
Preview the image and explore the metadata.

This completes the exercise.

Continue to the next exercise: Exercise 3a: Getting started with spatial ETL.
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Exercise 3a: Getting started with spatial ETL

Spatial ETL tools are capable of a wide range of processes and dataflows Complejidad:

. . . Intermedio
from simple format translations to complex transformations that restructure Requisitos de datos: .
geometry and attributes. 2?anﬁ|gSwaC|0n de datos de tutorial de
In thi i te a simpl tial ETL tool that extracts Int h
n this exercise, you creaie a simple spatia 00 at extracts Intergrap C:\arcgis\ArcTutor\Data Interoperability\
Modular GIS Environment (MGE) parcel data and loads it into a Objetivo: _

Create a simple spatial ETL tool that

geodatabase. reads MGE parcel data and loads it into a

geodatabase.
The MGE format uses standard MicroStation DGN files to store and edit the
graphic elements of geographic data. The nongraphic elements, such as
feature attributes, are stored in external database tables and linked to the graphic elements via pairs of entity
and mslink numbers.

You begin by using the Create Translation Workspace Wizard to perform the following tasks:
* Choose the FME reader and specify multiple data sources.

+ Specify the reader parameters for the external database.
* Choose the FME writer and start FME Workbench.

Using FME Workbench, you perform the following tasks:
* Prune the workspace so that it only processes the point and line features.

» Edit the destination parameter so that the path defaults to the tutorial folder.
+ Save the workspace and close Workbench.
* Open and run the spatial ETL tool from the Catalog window.

After running the tool and generating the data, you add the dataset to ArcMap to verify your results.

Requisito previo:
The Data Interoperability extension must be enabled.

Pasos:
1. Start ArcMap.
2. Click the Catalog Window button 3] on the Standard toolbar.

3. Type C:\arcgis\ArcTutor\Data Interoperability\parcels\ inthe Location text
box and press ENTER.
The location is added to the Catalog tree under the Folders Connection heading.
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Catalog il

| 2% B

Location: £ parcels -

= ] Data Interoperability *
3 birds_eggs
B major_roads
= parcels
|3 parcel_attrs.mdb
(&7 parcel_K24.par
'@ parcel_K25.par
& parcel_L24.par
[&D parcel_L25.par
=] a parcels.thx
&% Spatial ETL Tool

4. Right-click the parcels folder and click New > Toolbox .

5. Right-click the toolbox, click Rename, then name it parcels.

Create the translation workspace

Starting the Create Translation Workspace Wizard

Pasos:

1. Right-click the parcels toolbox and click New > Spatial ETL Tool.
The Create Translation Workspace Wizard opens.

Q Create Translation Workspace Wizard m

Welcome to the Create Translation Workspace Wizard
This wizard helps you set up a translation workspace.

Begin by selecting the format of your source data from the list
below, and dicking Next:

Intergraph MGE IL] [Z]

< Back I Mext = I[ Cancel

Choosing the FME reader

Pasos:

1. Click the Format browse button.
The FME Reader Gallery dialog box opens.
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r
&) FME Reader Gallery

Description : | Short Name Extensions Type Cn?
Intergraph MGE

Search Custom Formats EE,
mge New... H Import... Edit Delete... [ Ok ][ Cani

2. Type mge in the Search text box.

3. Click the row listing the Intergraph MGE format and click OK.
The FME Reader Gallery dialog box closes.

4. Click Next.

Specifying the data source

F
Q Create Translation Workspace Wizard m

Locate Source Data
Specify the location of your source data.

Yfou can also use the buttons to browse for files, or add multiple
datasets.

When you are finished, dick Next.
"C:\arcgis\ArcTutor\Data Interoperability \parcels\*. par”™ [I]

The reader has spedific parameters that you can adjust. Click
Parameters... if you want to change the default parameters.

Parameters...

< Back H Mext = ][ Cancel

1. Click the Add (+) button.
The Select Multiple Datasets dialog box opens.

2. Click the Add Directories button.
A second navigation window opens.

3. Navigate to C:\arcgis\ArcTutor\Data Interoperability\parcels\ and click
Open.

The Select Multiple Datasets dialog box is populated with the path and the standard (.dgn
and .cad) file extensions defined for the Intergraph MGE format by FME Reader Gallery.
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Specifying the file filter parameters

The next four steps edit the default File/Filter parameters to select the MicroStation DGN (.par) drawing
files used in this exercise.

Q Select Multiple Datasets 9 @Iéj

Directory FiIe.fFin Subdirectories Add Files...
Charcgis\ArcTutor\Data Interoperability'parcels  *.par |
- — Add Directories...
Charcgis\ArcTutor\Data Interoperability'parcels  *.cad | ’o
i 1
\ Remaove q
[ 1dentical Schema b [ OK 4 ] ’ Cancel ]

N\

e L

o

1. Double-click the File/Filter field containing *.dgn and replace the contents with * . par.
2. Click the row specifying *.cad and click Remove.

3. Click OK.
The Select Multiple Datasets dialog box closes.

4. Click Next.

Specifying the reader parameters

Specify the external database that contains the attribute tables.
Pasos:

1. Click the Parameters button.
The Intergraph MGE Parameters dialog box opens.

il B
B Intergraph MGE Parameters [ilﬂ_hj
Database Connection P

Databasze Type: [MDB v]

Access MDB File: zrability\parcels\parcel_attrs.mdb™ [Z]

ODBC Data Source} pused > A i
f A A b J

2. Click the Database Type arrow and choose MDB.
3. Click the Access MDB File browse button.

4. Navigate to C:\arcgis\ArcTutor\Data Interoperability\parcels\parcel_attrs.mdb and click

Open.
5. Click OK.

The Intergraph MGE Parameters dialog box closes.
6. Click Next.
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Choosing the FME writer

Pasos:

1. Click the Format browse button.
The FME Writer Gallery dialog box opens.

Q FME Writer Gallery 4

-

Description Short Mame Extensions Type

ESRI Geodatabase (File-based) GEODATABASE_FILE . Geodatabase

Search Custom Formats ~

gdb MNew... ] [ Import... Edit Delete... QK Can

2. Type gdb in the Search text box.

3. Click the row listing ESRI Geodatabase (File-based) and click OK.
The FME Writer Gallery dialog box closes.

4. Click Next.

Specifying the writer parameters

Accept the default parameters for the geodatabase.

Pasos:

1. Click Next.

Creating the workspace

Pasos:

1. Click Finish.
The wizard processes the information and starts Workbench.

Prepare the tool

Workbench opens the workspace with an ETL model of the information you provided. Prune the workspace
so that it only processes point and line features.

Modifying the model

Pasos:

1. Right-click the source feature type named unlinked and click Delete from the shortcut
menu.

2. Right-click its orphaned geometry filter and click Delete from the shortcut menu.
You may need to drag GeometryFilter 3 out of your way.
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3. Click and drag to create a selection box around the remaining orphaned destination feature
types, right-click the selection, then click Delete from the shortcut menu.

4. Delete all destination feature types except for source feature types LOT_LINES and
LOT_POINTS.
The LOT_LINES source feature type LINE attribute is mapped to the LOT_LINES_line
destination feature type, and the LOT_POINTS source feature type POINT attribute is
mapped to the LOT_POINTS_point destination feature type.

| Source Feature Types |71 | Dat Fiow |7| | Destnzton Festue Types |7|

[+|GeometryFiter 2 .| |

[ PoinT F#-

[ LINE —[¥ LOT_LL_FILE] [
[# ARc

[*] AREA

[#] ELLIPSE
TEXT

[#] RASTER
SURFACE
SOLID
COLLECTION
[# nuLL

[#] GeometryFitter_3

[+ LOT_P.. ar [GG]] % & INPUT

[ PoINT

[#] LINE

[# ARC

[# aRea

[ ELLIPSE

B BT

[#] RASTER

[# SURFACE

[ soLD

[# coLLECTiION

[# nuLL

. vvvvvvevey

[# LOT_P.._FILE] _|

P

A T i e o T P P s T

Specify the default output geodatabase path and file.
Pasos:

1. Confirm that Navigator is available.
Para abrir la ventana Navegador en el menu principal, haga clic en Ver > Ventana >
Navegador.
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Mavigator x

(& parcels\*par [GG]

[#-<5] <notset> [GEODATABASE_FILE]

= Transformers

Bookmarks

it Published Parameters

%t Source Bentley MicroStation GeoGraphics Fil
i

Workspace Resources

(=118 Tool Parameters

¢ Tool Name: <not set

@ Workspace Description: <not set>

18 Destination Redirect: No Redirect
G35 Advanced

{44 Workspace Search

o 3

2. Expand Published Parameters.

3. Double-click Destination ESRI Geodatabase (File-based).
The Edit Published Parameter dialog box opens.

€% Edit Published Parameter [l

Destination ESRI Geodatabase (File-based) File: teroperability\parcels\parcels_ETL.gdb B

&) o)

4. Click the browse button.

The Select Destination ESRI Geodatabase (File-based) File dialog box opens.

5. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\parcels folder.

6. Type parcels ETL.qgdb in the Geodatabase text box to complete the path and click

Open.

7. Click OK.
The Edit Published Parameter dialog box closes.

Pasos:
1. Click File > Save to save the tool.

2. Click File > Exit to exit Workbench.

3. Right-click the new spatial ETL tool in the Catalog window, click Rename, then type Import

MGE Parcels.

Pasos:
1. In the Catalog window, expand the Parcels toolbox .

2. Double-click the Import MGE Parcels tool.
The spatial ETL tool Import MGE Parcels dialog box opens.
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F -
i Import MGE Parcels = | B i)

Source Bentley MicroStation GeoGraphics File(s): i

=

C:\aregis\ArcTutor\Data Interoperability\parcels\®, par
+
+

Destination ESRI Geodatabase (File-based) File:
C:l\arcgis\ArcTutor\Data Interoperability\parcels\parcels_ETL.qdb @

AB

’ OK ] [ Cancel ] [Environments...] [ Show Help »> ]

3. Click OK.

The tool executes the conversion in the background. A progress bar at the bottom of your map
displays the name of the tool. When the tool is finished, a pop-up notification appears in the
system tray. You can examine the details of the conversion in the Results window.

Add the data to ArcMap

Pasos:

1. In the Catalog window, expand the parcels_ETL geodatabase and drag the feature classes

LOT_POINTS_pointand LOT_LINES_line into ArcMap and verify your results.

Table Of Contents B x
2 £ Layers

=] LOT_POINTS point
*

=] LOT_LINES line

i \‘\ w"‘“ '-4...#“. “

This completes the exercise.

Continue to the next exercise: Exercise 3b: Transforming data and verifying output.
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Exercise 3b: Transforming data and using Visualizer

A transformer is an FME Workbench object that performs a particular
restructuring of features or schema. It is a visual object that you add to your
workspace canvas and connect between the source and destination

features, or to other transformers.

This exercise introduces you to the fundamentals of using FME
transformers. You create a spatial ETL tool that transforms MGE parcel
data, evaluates the new features with a test clause, and generates output as
failed or passed features. Finally, you inspect the output of your workspace
without generating data using Visualizer. You complete the exercise by
exporting the workspace as a custom format.

Using FME Workbench, you perform the following tasks:

Complejidad:
Avanzado

Requisitos de datos:
Configuracion de datos de tutorial de
ArcGIS

Ruta de datos:
C:\arcgis\ArcTutor\Data Interoperability\
Objetivo:
Learn the fundamentals of transforming
features and attributes in FME
Workbench and using Visualizer to verify
output.

+ Add an AreaBuilder transformer to create polygons from the LOT_LINES source feature type.

» Add a PointOnAreaOverlayer transformer to overlay the LOT_POINTS features onto the polygon

features and merge their attributes.

* Add a Tester transformer to evaluate and count the point features inside each polygon feature.

» Redirect the output of the workspace to Visualizer and inspect the output of your workspace.

+ Export the workspace as a custom format.

Requisito previo:

The Data Interoperability extension must be enabled.

Before starting this exercise, you must have completed the previous exercise, Exercise 3a: Getting started

with spatial ETL.
Pasos:

1. Start ArcMap.

2. Click the Catalog Window button (3] on the Standard toolbar.

3. Type C:\arcgis\ArcTutor\Data Interoperability\parcels\ inthe Location text

box and press ENTER.

The location is added to the Catalog tree under the Folders Connection heading.
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Catalog

E

Gr oy @ E B
Location: £ parcels

B £ Charcgis\ArcTutor\Data Interoperability
3 birds_eqgs
B major_roads
El [ parcels
13 parcel_attrs.mdb
13 parcels_ETL.gdb
ﬁ parcel_K24.par
50 parcel_K25.par
50 parcel_L24.par
[0 parcel_L25.par
= @ parcels.thx
% Custom Parcels
Impog MGE Parcels
- ‘x—‘x._‘.‘

Pasos:

Custom Parcels.

Workbench starts.

Pasos:

1. Confirm that Transformer Gallery is available.
Para abrir la ventana Transformador en el menu principal, haga clic en Ver > Ventana >

Galeria del transformador.
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Right-click the Import MGE Parcel tool and click Copy on the shortcut menu.
Right-click the Parcels toolbox and click Paste on the shortcut menu.

Right-click the Import MGE Parcel (2) tool, click Rename on the shortcut menu, then type

Right-click the Custom Parcels tool and click Edit.

The AreaBuilder transformer creates topologically correct polygon features from lines that form closed
shapes.

Connect an AreaBuilder transformer to the LOT_LINES GeometryFilter.
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Transformers x

210 Al
- Categorized

-0 Recent

=-{=) Search Results
T g pr
"3 AreaBuilder
'S PolygonBuilder

Search: areabuilder -

AreaBuilder -
Forms area features from lines and
optionally cuts out any resulting holes

from their containers. The input lines
i

< topgli-aligprrectgliol gt |

In the Transformers window, type areabuilder in the search text box and press ENTER.

Double-click AreaBuilder.
An AreaBuilder transformer is added to the canvas.

Click the line connecting the LOT_LINES GeometryFilter and the LOT_LINES destination
feature and press DELETE.
The GeometryFilter is disconnected from the destination feature type.

On the LOT_LINES GeometryFilter, click the yellow arrow beside the LINE attribute output and
drag the arrow to the red arrow beside the AreaBuilder input.
The GeometryFilter output is connected to the AreaBuilder input, and the arrow turns green.

The PointOnAreaOverlayer transformer overlays point features onto area features and merges their
attributes. As a result, each polygon feature acquires attributes from the point feature contained within its
boundary. Attributes with the same name are not replaced.

Connect a PointOnAreaOverlayer transformer to the LOT_LINES AreaBuilder transformer and the
LOT_POINTS GeometryFilter.

Pasos:
1.
2.

In the Transformers window, type PointOnArea in the search text box and press ENTER.

Double-click PointOnAreaOverlayer.
A PointOnAreaOverlayer transformer is added to the canvas.

Click the Properties button and view the parameters.
The PointOnAreaOverlayer Parameters dialog box opens.
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- b
&% PointOnAreaOverlayer Parameters [ili_hj

Transformer

Transformer Mame:  PointOnAreaOverlayer
Group By: Mo items selected. B
Parameters

Overlap Count Attribute {optional): _overlaps

List Mame {optional):

| bep || Defaurs v| [ ok || cancel |

A

Overlap Count Attribute counts the number of point features contained in each polygon. This
is useful for validating data and sending features to separate outputs for further processing. In
the next section, you will connect a Tester transformer to evaluate this number and direct
output accordingly.

4. Click OK.
The PointOnAreaOverlayer Parameters dialog box closes.

5. Click the line connecting the LOT_POINTS GeometryFilter and the LOT_POINTS destination
feature type and press DELETE.
The GeometryFilter is disconnected from the destination feature type.

6. On the LOT_POINTS GeometryFilter, click the yellow arrow beside the POINT output and
drag the line to the red arrow beside the PointOnAreaOverlayer POINT input.
The GeometryFilter POINT output is connected to the PointOnAreaOverlayer POINT input,
and the arrow turns green.
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Source Feature Types |7| | Destinaton Feature Types |71
[E]GeometryFiter_3 J|
LOT P.ar [GGI .. P——— [
[# PoinNT
& LINE * ’_ LOT_P..._FILE]] J
[# aArc S
[ AREA B [#]PoirtOn.. Overlayer _. |
[H ELLIPSE S |
[ e B FOMT
[#] RaASTER B AREA l
[# FoINT B
[#l SURFACE = Bl aren .
[ soLD B
+]Geomemyrter 2 .j| [ couecton B
[# LOT_U..ar [GG]] % = | | [ nuLL B g LOT_LI._FILED |
& FOINT b [¥ AreaBuiider = |
[ LNE B—  INPLT |
[ arc B~ [ UNUSED_LINE B+
[ aArea B [# AREA
[+ ELLIPSE B
[ TEXT I
¥ RasTER B
[ suRFacE b
[ soLD B
B COLLECTION =
[#] MULL ﬂ>

At this time, the connectors may begin to cross over each other and appear confusing. There are several
ways to organize the canvas layout:
+ Click Tools > Auto Layout, then drag the objects on the canvas.

* Right-click a connector line, click Insert Vertex on link on the shortcut menu to add one more
vertex, then drag each vertex to route the connector around other transformers.

The Tester transformer evaluates one or more tests on a feature and routes the feature according to the
outcome of the test(s).

Connect a Tester transformer to the PointOnAreaOverlayer transformer. Add a test clause that evaluates
the Overlap Count attribute generated by the PointOnAreaOverlayer transformer. Send polygon features
containing one point feature to the PASSED output and all others to the FAILED output.
Pasos:
1. In the Transformers window, type Tester in the search text box and click Find.

2. Double-click Tester.
A Tester transformer is added to the canvas.

3. Connect the PointOnAreaOverlayer AREA output to the Test INPUT.
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\ [#/PointOn. Oveayer .|| [l Tester =
POINT | INPUT |

AREA | [# PasSSED =
¥ PoinT = [ Faen =
[¥] AReA

4. Click the Properties button on the Tester transformer.
The Tester Parameters dialog box opens.

&5 Tester Parameters @lé]

Transformer

Transformer Name:  Tegter

Parameters

Pass Criteria: [One Test (OR)

Comparison Mode: ’;_\ummaﬁc

Test Clauses: Left Value Op. Right Value

_overlaps 1

VLN can S S

Double-click the first cell in the Left Value field, click the down arrow, then choose _overlaps.
Double-click the first cell in the Op. field, click the arrow, then choose =.
Click the first cell in the Right Value field and type 1.

Click OK.
The Tester Parameters dialog box closes.

© N o o

Redefine the LOT_LINES destination feature to generate the polygon features that failed the test clause
specified in the Tester transformer. Also, add a user attribute to capture the _overlay value.

Pasos:

1. Connect the FAILED output on the Tester transformer to the INPUT on the LOT_LINES
destination feature.

[*| Tester I |
—  INPUT |
[+] PASSED B

[] FAILED B o151 provle EFILE] |

2. Click the Properties button on the LOT_LINES destination feature.
The Feature Type Properties dialog box opens.
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il b
€2 Feature Type Properties Iilﬂ_hj

General | > User Attributesl [ Format Attributes | 5 Parameters|

Mame Parameters

Feature Type Name: problem_polys

[T Fanout By Attribute

General Parameters

Allowed Geometries: [geodbjoly‘lir‘le ']

Dataset: | parcels_ETL [GEODATABASE_FILE]
e o VR e P

3. Click the General tab.
4. Inthe Feature Type Name text box, type problem polys.
5. Click the Allowed Geometries arrow and choose geodb_polyline.
6. Click the User Attributes tab.
[ Q Feature Type Properties I_I_J? | )
General| 7 User Attributes | > Format Attributes | IE:E Parameter5|
Attribute Name Data Type Width | Dec.
rum sori rese

— I & "

7. Select all attributes and press DELETE.
The LOT_LINES attributes are not needed.

8. Click the first empty cell in the Attribute Name field and type num points.
The num_points attribute is used to capture the _overlay attribute value generated by the
Tester transformer. This value represents the quantity of overlapping points for each failed
feature.

9. Click the Data Type arrow and choose integer.

10. Click OK.
The Feature Type Properties dialog box closes.

11. Expand the Tester transformer and connect the _overlay output to num_points on the
LOT_LINES destination feature.

[=] Tester =l ‘
INFUT | = parcels..._FILE]) J‘
[ PASSED
=] FAILED || e proble.. E_FILE]] J|
_overlaps =] F=num_paints
AREA k=
BLOCK_ID B
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Redefine the LOT_POINTS destination feature

Redefine the LOT_POINTS destination feature to generate the polygon features that passed the test clause
specified in the Tester transformer.

Pasos:

1. Connect the PASSED output on the Tester transformer to the INPUT on the LOT_POINTS
destination feature.

[#] Tester = |

[&] parcels___FILE]] _||
——  INFUT
[#] PASSED |f
W FALED 5] proble_E_FILE] _||

2. Click the Properties button on the LOT_POINTS destination feature.
The Feature Type Properties dialog box opens.

[ &2 Feature Type Properties M‘

General | [» User Attributesl [» Format Attributes | 1:':’:! Parameters|

Mame Parameters

Feature Type Name: parcels

|| Fanout By Attribute

General Parameters

Allowed Geometries: [geodbjoint ']

Dataset: s gt [GE0DATABASE FILE] .-

3. Click the General tab.
4. Inthe Feature Type Name text box, type parcels.
5. Click the Allowed Geometries arrow and choose geodb_polyline.
6. Click the User Attributes tab.
[ &2 Feature Type Properties M‘
General| 7 User Attributes | [ Format Attributes | i Parameter5|
Attribute Name | DataType | Widih | Dec. | +
AREA double -
BLOCK_ID char -2
FLAG double -
LOT char -2
LUS0 double - =
RN Y TN

7. Select only the attributes with names that start with 1gds_and press DELETE.
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The igds__ attributes are symbolic names created by the FME reader to simplify the translation

of the IGDS source element types to FME feature types. There is no need to include them with
the destination features.

8. Click OK.
The Feature Type Properties dialog box closes.

Verify the output of your workspace with Visualizer

Visualizer is an in-memory viewer that enables you to inspect the output of your workspace without
generating data or possibly overwriting existing data.

Redirect the output of your workspace to Visualizer and verify your results.
Pasos:

1. In the Navigator window, expand Tool Settings, right-click Destination Redirect, then click
Edit Parameter from the shortcut menu.

The Edit Parameter dialog box opens.

~ y

Mavigator x

[#-5] parcels_ETL [GEODATABASE_FILE]

E Transformers

o] Bockmarks F

EI# Published Parameters
# Source Bentley MicroStation GeoGraphics
# Destination ESRI Geodatabase (File-base

Workspace Resources

=-18F Tool Settings

--78F Tool Name: <not set>

@ Waorkspace Description: <not set=>

=-38F Adv

»

m

L.fr @ € Edit Parameter @Iﬂ_hj
e
..... 75 1{ | Destination Redirect: [Redirecttc Visualizer v]
T
s = o) [ oo
B4 [ || concl |

(il Searchr

T b

Search: h

2. Click the Destination Redirect arrow and choose Redirect to Visualizer.
3. Click OK.
The Edit Parameter dialog box closes.

4. On the main menu, click File > Run Translation.
Visualizer starts.
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45 Visualizer - [View 0 (fmetool-a04876_294378424 0_215828)] =g
G File View Window Help
| R 2@LMAa QAo ms BES
Bl=l | Wiewd
45 Viewspace Feature: |1 of 1 )
EE@ e [ Feature Type: | parcels
- EIE#] Dataset: FFS (fmetc
BEE parcels Coord Sys: Unknown
OLE A \
i Eg Lir:: Attribute Name Attribl.?
B+ Paoint _wh_out_feat_typ... parcels
A Test _overlaps 1
BEE problem_polys AREA 2248674
ED Ares BLOCK_ID 01
B Line category 1 Y
B+ Paint "'-
EA Test Bounding Box: ?
o5 Lower Left: (312544
Upper Bight: (31273
N rm\_ ppegpa = o "‘\_ "'“" ™ il F

5. Expand the datasets in Viewspace.

6. Click the Identify tool on the toolbar, select features, then explore their attribute values
displayed in the Information window.

Observe that the workspace creates polygons from line elements stored in the MicroStation
DGN (.par) files and acquires the point feature attributes stored in the parcels_attr.mdb
database. Also observe that the Tester transformer routed features that did not pass the test
clause to the problem_polys destination features.

7. Exit Visualizer.

8. On the Workbench menu, click File > Save.

A custom format is a translation workspace that is exported as a format and utilized in the FME reader
gallery. It is saved to an external (.fds) file and can be imported to reader galleries on other desktops.

Creating a custom format adds the format to the FME reader gallery. Once created, subsequent uses of the
gallery allow you to edit the format in FME Workbench or delete it from the list and remove the (.fds) file
from the default folder location.

Pasos:

1. On the Workbench menu, click File > Export as Custom Format.
The Set Custom Format Name and Description dialog box opens.

&% Set Custom Format Name and Description |l|éj

New Custom Format Name: Custom_Parcels

New Custom Format Description:  Custom Parcels
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2. Type Custom_ Parcels in the New Custom Format Name text box.

3. Type Custom Parcels in the New Custom Format Description text box.

4. Click OK.
A second Workbench session starts as a custom format (.fds) workspace.

5. Click File > Exit to close the custom format workspace.

6. Click File > Exit to close the transformation workspace.

This completes the exercise.

Continue to the next exercise: Exercise 3c: Using attribute values to control output.
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Exercise 3c: Using source attributes to separate data

This exercise introduces two methods for separating data based on attribute Complejidad:
A d
values. They can be used to create spatial ETL tools that categorize source raneac

Requisitos de datos:

data and generate sets of features with common values. gfcneﬁgswacif’" de datos de tutorial de
The first method separates the data within the workspace using the R e AreTutorData Insroperabllity
ValueMapper transformer as a lookup table and routes the data to specific Objetivo: _

N Learn how to use source attribute values
AutoCAD block definitions. The second method separates the data at the in FME Workbench to separate data and

. " . . . generate new features.
time of writing using the Fanout By Attribute writer parameter for a GML

dataset and generates unique feature types on the fly.

Using Workbench, you perform the following tasks:
+ Add a ValueMapper transformer and map specific attribute values in the COVER field to AutoCAD
block definitions stored in the AutoCAD template (.dwg) file.

» Expose the AutoCAD properties for the block name, block rotation, and the block reference (insert)
entity.

» Specify the AutoCAD template file that is included with the tutorial data.

* Add a second data destination for a GML dataset and set the Fanout By Attribute parameter for each
unique value in the COVER field.

Requisito previo:
The Data Interoperability extension must be enabled.

Pasos:
1. Start ArcMap.
2. Click the Catalog Window button (3 on the Standard toolbar.

3. Type C:\arcgis\ArcTutor\Data Interoperability\birds eggs\ inthe Location
text box and press ENTER.
The location is added to the Catalog tree under the Folders Connection heading.

Catalog @
-l @ E-alE
Location: [ birds_eggs -
=1 3 Data Interoperability -
= [ birds_eggs

# (3 nests.gdb
+ [50 template.dwg
= @ nests.thx
&% Spatial ETL Tool L

it r-ﬁp—..:;*_w-m—\m r—--.‘__’:'"‘

4. Right-click the birds_eggs folder and click New > Toolbox .
5. Right-click the toolbox, click Rename, then type nests.

6. Right-click the nests toolbox and click New > Spatial ETL Tool.
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Create Translation Workspace Wizard opens.

Q Create Translation Workspace Wizard m

Welcome to the Create Translation Workspace Wizard
This wizard helps you set up a translation workspace.

Begin by selecting the format of your source data from the list
below, and dicking Next:

ESRI Geodatabase (File-based) - [B

< Back |I Mext > I[ Cancel

Create the translation workspace

Choosing the FME reader

Pasos:

1. Click the Format button.
The FME Reader Gallery dialog box opens.

&) FME Reader Gallery

-

Description Short Mame Extensions Type
ESRI Geodatabase (File-based) GEODATABASE_FILE . Geodatabase

Search Custom Formats

<
gdb New.. ][ mport.. || Edt || pelete.. | [ oK || copd

|

2. Type gdb in the Search text box.

3. Click the row listing the ESRI Geodatabase (Filed-based) format and click OK.
The FME Reader Gallery dialog box closes.

4. Click Next.

Specifying the data source

Pasos:

1. Click the Locate Source Data browse button.
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The Select Geodatabase dialog box opens.

Q Create Translation Workspace Wizard m

Locate Source Data
Specify the location of your source data.

You can also use the buttons to browse for files, or add multiple
datasets,

When you are finished, dick Next.
gis\ArcTutor'\Data Interoperability \birds_sggs'nests.gdb™ B

The reader has spedfic parameters that you can adjust. Click
Parameters... if you want to change the default parameters,

<o ] (o> ) [Comm ]

2. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\birds eggs\
folder.

3. Click the nests.gdb folder and click Open.
The Select Geodatabase dialog box closes.

4. Click Next.

Specifying the reader parameters

Accept the default parameters for the geodatabase.
Pasos:

1. Click Next.

Choosing the FME writer

Pasos:

1. Click the Format browse button.
The FME Writer Gallery dialog box opens.

.
&) FME Writer Gallery !

Description . Short Name Extensions Type C‘t

Autodesk AutoCAD DWG/DXF  ACAD

Search Custom Formats
dwg New... || import.. Edit Delete... [ ok || can
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2. Type dwg in the Search text box.

3. Click the row listing ESRI Geodatabase (File-based) and click OK.
The FME Writer Gallery dialog box closes.

4. Click Next.

Accept the default parameters for the AutoCAD DWG format.

Pasos:

1. Click Next.
Pasos:

1. Click Finish.

The wizard processes the information and starts Workbench.

| Source Feature Types |71

| Destination Feature Types |71

[=] NESTS. _FILE] ¢
- -

geodb_oid
WING_LEN_MM
NUM_HATCHED
COVER
BIRD_AGE
NUM_LIVE
NUM_EGGS
BAND_NUM
FAT_INDEX
BIRD_KILLED
NEST_ID
HATCH_DATE
YEAR
LAY_DATE
NEST_FATE
WEIGHT_G
ROTATION
Object_ID

FYvY Y Y YYVYVY VY VP Y YVY YT Y VYWY

g-[=] NESTS._ACAD] .|

-geodb_oid
FWING_LEN_MM
FNUM_HATCHED
-COVER
FBIRD_AGE
NUM_LIVE
BNUM_EGGS

- BAND_NUM

[ FAT_INDEX
FBIRD_KILLED
=NEST_ID
WHATCH_DATE
B YEAR

LAY _DATE
ENEST_FATE
B-WEIGHT_G
FROTATION

- Object_ID

2. Expand the source dataset NESTS and the destination feature NESTS. Observe that the
source feature attributes are mapped directly to the destination AutoCAD dataset.

The ValueMapper transformer acts as a lookup table for input values and stores the output values in a user-

defined attribute.

Map the unique values in the COVER feature attribute field to specific AutoCAD block names stored in the

block_name attribute field.

Pasos:
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1. In the Transformers window, type valuem in the search text box and press ENTER.

2. Double-click ValueMapper.
A ValueMapper transformer is added to the canvas.

3. Right-click the ValueMapper transformer and click Insert Before from the shortcut menu.
Workbench Wizard starts.

¢ Workbench Wizard [

Select Destination Node
Select the node that you NESTS [<not sst> [ACAD]]
would like to insert this
transformer before.
Help << Back Ned>> | | Caneel

4. Click Next.
The transformer is connected to the source and destination datasets.

| Source Feature Types ﬁ | Data Flow ﬁ | Diestination Feature Types |71
[#] NESTS.._FILET] .. [] ValueMapper .| [#] NESTS. ACAD]] J|
INPUT ’—/_'

5. Click the Properties button on the ValueMapper transformer window.
The Edit ValueMapper Parameters dialog box opens.
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[ Q Edit ValueMapper Parameters I_I—J@ ot e |
Transformer Parameters
Transformer Name: ValueMapper
Source Attribute: |COVER -
New Attribute Name:  block_name

Value Mappings:
Default value: | oysk

rock KRYSS
. willow BARRTR
Unique values for the | i | A
) utoCAD block names
COVER attribute | conifer STOMPKT |
bare LOVTR
|:| Reverse Mapping

[ Ok ][ Cancel ]

6. Click the Source Attribute arrow and choose the Cover attribute.

7. Inthe New Attribute Name text box, type block name.

Importing unique values

You can type the source input values manually or use the import wizard. You can use the import wizard
even when the destination values are unavailable. In this case, select the same source attributes for both
sides of the equation to generate a basic 1:1 mapping, then edit the destination values to match the
corresponding AutoCAD block names stored in the template (.dwg) file.

Pasos:

1. Click Import.
Workbench Wizard starts.

Copyright © 1995-2012 Esri. All rights reserved.



Data Interoperability Extension Tutorial

10.

© N o o 0D

€ Workbench Wizard -2 ]

e R

Select Dataset

Select the dataset to be read. The features
in the dataset will be scanned, and the
attribute values found will be added to
ValueMapper list,

Reader

Format: GEODATABASE FILE

Dataset: nteroperability'\birds_eggs\nests.gdb

Help <= Back [ Mend == ] [ Cancel ]

Confirm the path is set to C:\arcgis\ArcTutor\Data Interoperability\birds_eggs\nests.gdb.
Click Next.

Click the feature type NEST and click Next.

Click the key attribute COVER and click Next.

Click the value attribute COVER and click Next.

Click Finish.

In the Default Value text box, type LOVSK.

During execution, the default value is used if the tool encounters an attribute value not listed
in the ValueMapper lookup table. In this exercise, you are providing a default AutoCAD
block name.

Double-click each value in the right-hand column and replace it with the corresponding
AutoCAD block name listed in the following table.

COVER attribute value block_name attribute value
rock KRYSS

willow BARRTR

conifer STOMPKT

bare LOVTR

Click OK.

The Edit ValueMapper Parameters dialog box closes.

Expose the AutoCAD block properties

Exposing the AutoCAD block properties in the destination feature type enables you to control how the block
references are inserted in the destination AutoCAD (.dwg) file.
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Pasos:

1. Click the Properties button on the destination feature type NESTS.
The Feature Type Properties dialog box opens.

' b
&2 Feature Type Properties [ili_hj
| Generall L User Attributes| I Format Attributes | % Parameters

Bxposed Attribute BElements -
autocad_attibutes_follow 1

autocad_base_x

autocad_base_y
autocad_base_z
autocad_big_fontname
autocad_block_name
autocad_box_height
autocad_box_width
autocad_bulge
autocad_closed_spline
autocad_color

autocad_control_weights

B R O A A

autocad_control_x 1 -

| Select Al || Deselect Al |

[“\DDWtO--- ][ OK ” Cancel

A

2. Click the Format Attributes tab.
3. Check the boxes for autocad_block_name, autocad_entity, and autocad_rotation.

4. Click OK.
The Feature Type Properties dialog box closes.

Pasos:

1. Expand the attributes list for the ValueMapper transformer and the NESTS destination feature.

P

T /""-NEs'i':l’:ATE v” _‘--m_.-'liT|di‘l-,./‘h-."‘-“"/ o
WEIGHT G b F-Object_ID
ROTATION B [autoca.. ck_name
Object ID - F-autocad_entity
block name B F-autocad_rotation

MJ\ L -‘a—AJ [ “_ﬂ‘,\ \' .

Pan to the bottom of the lists and make the following connections:

2. Connect the ROTATION attribute to the autocad_rotation format attribute.
The rotation values are passed from the source data.

3. Connect the block_name attribute to the autocad_block_name format attribute.
The block_name values are generated by the ValueMapper lookup table.
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Double-click the autocad_entity input (red) arrow.

New Constant appears as input.

Double-click New Constant and type autocad insert.

The autocad_insert constant instructs FME Writer to insert a block reference for each output
entity. In addition to the graphic elements defined in the AutoCAD template (.dwg) file, the user
attributes specified for the destination dataset are written as block attributes to each block

reference.

Specify the AutoCAD template file

The AutoCAD template file contains the block definitions you specified in the ValueMapper lookup table.

Pasos:
1.

In the Navigator window, expand the destination format Parameters, right-click Template
the shortcut menu.

File, then click Edit Parameter from

The Edit Parameter dialog box opens.

MNavigator

- [E nests [SEODATABASE_FILE]
El-<5] <not sets [ACAD]

----- @ Coordinate System: <not set=
{ Parameters

3Hr AutoCAD Version: Release2007

¥ Template File: <not set>

- Destination Autodesk AutoCAD DWG/DXF File

---Fea &% Edit Parameter

T et |

-5 Transfon

Bookmark| | Template File: :roperability\birds_eggs\template. dwg” [:]

o | [ oo |

Workspace

=-48F Tool Settings
¢35 Tool Name: <not set
[ (é:t Workspace Description: <not set>

----- {5r Destination Redirect: No Redirect
(-3¢ Advanced
@ Search results

4 | i |

Search:

Click the browse (...) button.

The Select Template File dialog box opens.

Navigate to the C:\arcgis\ArcTutor\Data Interoperability\birds_eggs folder, click template.dwg,

then click Open.
Click OK.

Save your work and exit Workbench.

Save and rename the tool

Pasos:
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1. Click File > Save to save the tool.
2. Click File > Exit to exit Workbench.

3. Right-click the new spatial ETL tool in the Catalog window, click Rename, then type Nests
to AutoCAD.

Pasos:
1. In the Catalog window, expand the Nests toolbox .

2. Double-click the Nests to AutoCAD tool.
The Nests to AutoCAD dialog box opens.

B Nests to AutoCAD =NacN X

Source ESRI Geodatabase (File-based) File:

C:larcgisiArcTutor\Data Interoperability\birds_eggsinests.gdb

«

Destination Autodesk AutoCAD DWG/DXF File:
Cilarcgis\ArcTutor\Data Interoperability\birds_eggsinests.dwg

[ OK ] ’ Cancel ] [En\tironments... ] ’ Show Help == ]

A

3. Click OK.
The tool executes the conversion in the background. A progress bar at the bottom of your map
displays the name of the tool. When the tool is finished, a pop-up notification appears in the
system tray. You can examine the details of the conversion in the Results window.

Pasos:

1. In the Catalog window, expand the nests DWG dataset and drag the point feature class into
ArcMap to confirm your results.
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Table Of Contents 1 x ;
N .
= = layers * . ¥ o
= £ Charcgis\ArcTutor,Data Inter ’.‘ "
= T nests.dwg v -’ )
=1 nests.dwg Point + f '
o+,
& <alloth L
c| Table '
S (EHEHEY P 1
+ CC :
nests.dwg Point

Reflame | Angle | NEST_ID | ROTATION | FAT_INDEX | YEAR | WEIGHT_G

k| KRYS3 281.007 20 281.007 1275 &8 460

KRY3S 225 21 225 -7.38 &8 380

BARRTR 218.018 22 218.18 -0.27 88 455
KRY'SS 277.on 23 277.0m 2256 85 445 J

BARRTR 121.014 24 121.014 52 &89 455

BARRTR 27701 25 277.01 0 89 438

BARRTR 94.014 26 94.014 -10.8 89 430

S, gt A8 STl gasisl 4 AW N

Copy and rename the tool

Pasos:

1. In the Catalog window, right-click the Nests to AutoCAD tool and click Copy on the shortcut
menu.

2. Right-click the Nests toolbox and click Paste on the shortcut menu.

3. Right-click the Nests to AutoCAD (2) tool, click Rename on the shortcut menu, then type
Nests to AutoCAD and GML.

4. Right-click the Nests to AutoCAD and GML tool and click Edit.
Workbench starts.

Add a writer for GML
Add a writer and connect a second destination dataset for GML to the ValueMapper transformer OUTPUT.

Pasos:

1. On the main menu, click Writers > Add Writer.
The Add Writer dialog box opens.

5] Add Writer LB [
Writer
Format:  GML (Geography Markup Language) - E

Dataset: cTutor\Data Interoperability \birds_egagsinests.gdbinests.gml” B

Parameters... Coordinate System: Same as source B
Waorkflow Options

@ Static Schema () Dynamic Schema

o] (o ]
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10.
11.

12.
13.

Click the Format browse button and choose Geography Markup Language (GML) from FME
Writer Gallery.

Click the Dataset browse button.
The Select File dialog box opens.

Navigate to the C:\arcgis\ArcTutor\Data Interoperability\birds_eggs\ folder, type nests in the
File name text box, then click Save.

Click OK.
Workbench prompts you to create a new feature type.

Click No.

Instead of creating a feature type from scratch, copy the AutoCAD feature type and edit the
settings.

Right-click the AutoCAD output feature type NESTS and click Duplicate from the shortcut
menu.

Connect the ValueMapper OUTPUT to the INPUT of the new destination feature type.

| Source Feature Types | Destnation Feature Types |7|
. NESTS... FILET E Va|ueMappe[ E NESTS..ACAD]] J‘
INPUT
[#] oUTPUT [*] NESTS..ACAD]] J‘

Click the Properties button on the destination feature type NESTS.
The Feature Type Properties dialog box opens.

- |
@ Feature Type Properties Iili_hj

General | [ User Attributesl > Format .nttributes|

Mame Parameters

Feature Type Name: | NESTS_gm

Fanout By Attribute | COVER v

General Parameters

Allowed Geometries: | <Al

Dataset: |nests [GML] v | | petsis.... |

Database Username:

F 40 - 0" vt~ o J

In the Feature Type Name text box, type NESTS gml.

Check the Fanout By Attribute check box, click the arrow, then choose COVER.
The Fanout setting generates a new output feature type on the fly for each unique value in the
COVER attribute field.

Click the Dataset arrow and choose nests [GML].

Click OK.
The Feature Type Properties dialog box closes.
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Save and run the tool

Pasos:
1. Click File > Save to save the tool.
2. Click File > Exit to exit Workbench.
3. Inthe Catalog window, expand the Nests toolbox .
4

Double-click the Nests to AutoCAD tool.
The Nests to AutoCAD dialog box opens.

] Nests to AutoCAD and GML =NNEN X

Source ESRI Geodatabase (File-based) File:

C:larcgis\ArcTutor\Data Interoperability\birds_sggsinests.gdb

« [+ [x] = @

Destination Autodesk AutoCAD DWG/DXF File:

C\arcgis\ArcTutor\Data Interoperability\birds_eggsnests.dwg
Destination Geography Markup Language (GML) File:
C\arcgis\ArcTutor\Data Interoperability \birds_eggsnests.aml
[ Ok ] ’ Cancel ] [En\tironments. . ] ’ Show Help == ]
\
5. Click OK.

The tool executes the conversion in the background. A progress bar at the bottom of your map
displays the name of the tool. When the tool is finished, a pop-up notification appears in the
system tray. You can examine the details of the conversion in the Results window.

Add the data to ArcMap

Pasos:
1. In the Catalog window, drag the nests GML dataset into ArcMap to verify your results.
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This completes the exercise.
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