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An overview of the linear referencing tutorial
ArcGIS has the tools you need for linear referencing applications. The easiest way to start learning about
linear referencing is to complete the exercises in this tutorial. Before you start, however, it is assumed you
know the fundamentals of ArcGIS software. For more information, see A quick tour of geoprocessing, A quick
tour of ArcCatalog, and A quick tour of editing.

For this tutorial, imagine that you work in the GIS department of a highway authority, responsible for the
maintenance and safety of your region’s highways. In the exercises to follow, you will perform some of the
linear referencing tasks typical to such a person. Specifically, you will use the linear referencing geoprocessing
tools to create and recalibrate route data. Next, you will learn how to display and query your newly created
route data, then your route event data, in ArcMap. Lastly, you will learn how to edit your route data in ArcMap.

This tutorial includes five exercises, each of which takes 5 to 30 minutes to complete. The exercises build on
one another, so it is assumed that you will complete them in order.

The study area for this tutorial is Pitt County, North Carolina. The data was compiled from various sources and
has been modified to suit the needs of the exercises. The reliability and suitability of the information, therefore,
cannot be guaranteed.
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Exercise 1: Organizing your linear referencing data in
ArcCatalog
The exercises in this chapter use the tutorial data distributed with ArcGIS
and work with an ArcView license. Some of these exercises require you to
make changes to the data; therefore, you will need to have write access to
the data. To be sure you have write access, you will begin this exercise by
making a working copy of the LinearReferencing tutorial folder.

Copying the data

Steps:

1. Start ArcCatalog by clicking Start > All Programs > ArcGIS > ArcCatalog 10.

2. Navigate to the LinearReferencing folder on the local drive where the tutorial data is
installed—for example, C:\arcgis\ArcTutor\LinearReferencing.
If the data was installed by your system administrator in a shared folder on the network, the
path to the tutorial folder includes the names of the computer and the connection through
which the folder is accessed—for example,
\\dataserver\public\ArcGIS\ArcTutor\LinearReferencing.

3. Right-click the LinearReferencing folder and click Copy.

4. Navigate to the location where you would like to make a copy of this data, such as the C drive.

5. Right-click this location and click Paste.
A new folder called LinearReferencing is created at this location.

6. Right-click this new folder and click Rename.

7. Type MyLR as the new folder name.

Connect directly to your tutorial data

In ArcCatalog, folder connections let you access specific directories on local disks or shared folders on the
network. Further, database connections allow you to access the contents of a database.

Steps:

1. Click the Connect To Folder button on the Standard toolbar.

2. Navigate to and choose the location of your MyLR folder.

3. Click OK.

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Goal:
Organize the linear referencing tutorial
data in ArcCatalog.
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The new folder connection is now listed in the Catalog tree.

You will now be able to access all the data needed for the remaining exercises in this tutorial via the new
connection.
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Exercise 2: Creating and calibrating route data
The first thing you will need for any linear referencing project is accurate
route data. In this exercise, you use tools in the Linear Referencing toolbox
to create and calibrate route data. The first activity is to create a temporary
layer representing only the line features that have route and measure
information stored as attribute values. Next, you will create a route feature
class by merging the input line features of the temporary layer that share a
common route identifier. Finally, you will recalibrate the newly created routes
using a point feature class storing route and measure information as attributes.

Creating a layer

Not every feature in the base_roads feature class has route and measure information. Therefore, before any
routes are created, you will want to isolate only those routes that contain this information. Creating routes
using features that do not have this information would be pointless.

Creating a temporary layer allows you to do things, such as make selections, without affecting the original
data source. This layer will not appear in the ArcCatalog table of contents, because it is created inmemory
and simply references the data stored on disk. These layers can be used as inputs to other geoprocessing
tools within your working session. Once you exit the application, the in-memory layers will be removed.

Steps:

1. In ArcCatalog, expand the Toolboxes folder in the Catalog tree.

2. Expand System Toolboxes to show its contents.

3. Expand the Data Management Tools toolbox to show its contents.

4. Expand the Layers and Table Views toolset to show its contents.

5. Right-click the Make Feature Layer tool and click Open. Alternatively, you can double-click
the Make Feature Layer tool to open it.

There are several ways to set the input feature class. You can drag a feature class from the
ArcCatalog tree and drop it onto the text box, click the browse button and navigate to the
feature class in the dialog box, or simply type the full path to the feature class in the text box.

The tutorial instructions ask you to type names and paths into the appropriate text boxes. Feel
free, however, to use any of the available techniques.

6. Type C:\MyLR\PITT.gdb\PITT\base_roads for the value of the Input Features
parameter.

7. Type measured_roads for the value of the Output Layer parameter.

8. Click Expression.
The Query Builder dialog box opens.

9. Type "ROUTE1" <> 0 in the text box.

10. Click OK on the Query Builder dialog box.

11. Click OK on the Make Feature Layer dialog box.

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Goal:
Creating and calibrating route data using
the linear referencing geoprocessing
tools.
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A status bar appears in the lower right of your screen as the tool runs. When the tool
completes, a status message appears.

Creating route data

The Create Routes tool is used to specify the input line features, the route identifier field, the method used to
set the route measures, and the output feature class. Note that the input features can be any supported
format. This includes coverage, shapefile, personal, file, and enterprise geodatabases and computer-aided
design (CAD) data.

Steps:

1. Expand the Linear Referencing Tools toolbox to show its contents.

2. Right-click the Create Routes tool and click Open.

3. Click the Input Line Featuresdrop-down arrow and click the measured_roads layer.

4. Click the Route Identifier Field drop-down arrow and click ROUTE1.
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The values in the route identifier field uniquely identify each route.

Next, you need to specify the name for the output feature class. This feature class can be
contained within the same geodatabase as the input, or you can save it to another geodatabase
or shapefile. If it is saved to a geodatabase, it can be contained within a feature dataset or on its
own as a feature class. For this exercise, you will be writing the new data to the same feature
dataset as the input.

5. Type C:\MyLR\PITT.gdb\PITT\routes for the value of the Output Route Feature Class
parameter.

Next, specify how the route measures will be obtained. There are three choices:

• LENGTH—Geometric lengths of the input features are used to accumulate the
measures.

• ONE_FIELD—Values stored in a measure field are used to accumulate the measures.

• TWO_FIELDS—Values stored in from- and to-measure fields are used to set the
measures.

You will use the last method.

6. Click the Measure Source drop-down arrow and click TWO_FIELDS.
This enables both the From- and To-Measure Field input fields.

7. Click the From-Measure Field drop-down arrow and click BEGMP1.

8. Click the To-Measure Field drop-down arrow and click ENDMP1.

9. Click OK to execute the tool.

A status bar appears in the lower right of your screen as the tool runs. When the tool
completes, a status message appears.
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Calibrating route data

Imagine that at some point in the future, the highway authority's road maintenance crew acquires a distance
measuring instrument (DMI) to accurately record mileage information along the highways. For a sample set
of highways, the crew goes out and captures mileage information approximately every 1/10 of a mile. The
results of this effort are stored as points in a shapefile, where the route and mileage information are stored
as attributes.

In the next section of this tutorial, you will use the Calibrate Routes tool to adjust the measures of the routes
you just created to match those of the points in the shapefile. The result will be written to a new feature
class.

The Calibrate Routes tool is used to specify the input route feature class, the route identifier field, the input
point feature class, the measure field, the methods used to set the route measures, and the output feature
class.

Steps:

1. Right-click the Calibrate Routes tool in the Linear Referencing toolbox and click Open.

2. Type C:\MyLR\PITT.gdb\PITT\routes for the value of the Input Route Features
parameter.

3. Click the Route Identifier Field drop-down arrow and click ROUTE1.
The values in the Route Identifier Field uniquely identify each route.

4. Type C:\MyLR\calibration_points.shp for the value of the Input Point Features
parameter.

5. Click the Point Identifier Field drop-down arrow and click ROUTE1.
This is the common field, shared with the route feature class.

6. Click the Measure Field drop-down arrow and click MEASURE.

7. Type C:\MyLR\PITT.gdb\PITT\routes_new for the value of the Output Route Feature
Class parameter.

A tolerance can be specified to limit how far a calibration point can be from its route. Points
outside the tolerance will not be used by the calibration process.

8. Click the Measure Calculation Method drop-down arrow and click DISTANCE.

9. Type 5 for the value of the Search Radius parameter.
This is more than enough for the data that is being used here.

10. Click the Search Radius drop-down arrow and click Feet.
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This sets to feet the units to be used for the search radius.

11. Click OK to execute the tool.

A status bar appears in the lower right of your screen as the tool runs. When the tool
completes, a status message appears.

In this exercise, you learned how to create a route feature class by merging input line features that shared a
common identifier and how to adjust the route measures using measure information stored in a point shapefile.
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Exercise 3: Displaying and querying routes
In this exercise, you will add the route data you created in Exercise 2
Creating and calibrating route data to an existing map document and
symbolize it. You will then do the following:

• Set the route identifier field.

• Add the Identify Route Locations tool to a toolbar.

• Identify route locations.

• Find route locations.

• Display route measure anomalies.

If you have not completed Exercise 2 Creating and calibrating route data, open ArcCatalog. Within the table of
contents, delete PITT.gdb in your \MyLR folder and rename PITT_Results.gdb to PITT.gdb.

Open an existing map document

To begin this exercise, you will start ArcMap and open an existing document.

Steps:

1. Start ArcMap by clicking Start > All Programs > ArcGIS > ArcMap 10.

2. In the Getting Started dialog box, choose Existing Maps.

3. Double-click Browse for more.

4. Click the Look in drop-down arrow in the Open dialog box and navigate to the folder where
you copied the data for this tutorial (in other words, C:\MyLR).

5. Click Ex3.mxd.

6. Click Open.

This map contains the following layers in a data frame called Pitt County:

calibration_points The points used in exercise 2 to recalibrate the route measures

base_roads All the roads in Pitt County

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Goal:
Displaying and querying routes
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city boundaries The boundaries of the cities in Pitt County

county boundary Pitt County boundary

The map currently displays the city boundaries and county boundary layers. Their check boxes
are checked in the table of contents. The calibration_points layer is checked, but scale
suppression has been set. It will only be visible when you zoom in to a scale beyond 1:25,000.

7. Check the box next to the base_roads layer in the contents.

You will now see all the roads in Pitt County. This includes roads not maintained by the highway
authority. The roads maintained by the highway authority were written to the routes feature
class.

Adding route data to your map

Steps:

1. Click the Add Data button.

2. Click the Look in drop-down arrow and navigate to your \MyLR folder.

3. Double-click PITT.gdb and double-click the PITT feature dataset.

4. Press the CTRL key and select both the routes and routes_new feature classes.

5. Click Add.
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Changing the display symbol

The default colors and symbols with which ArcMap displays the routes layer might make it difficult to see
where the route features are located. It is easy to change the colors and symbols used to display features in
ArcMap.

Steps:

1. Click the line symbol in the contents for the routes layer to display the Symbol Selector
dialog box.

2. Scroll down until you find a symbol you like and click it.

3. Click OK.
Your routes layer is displayed with the symbol you chose.

4. Repeat steps 1 through 3 for the routes_new layer.

Tip: You can also open the Symbol Selector dialog box by right-
clicking the layer in the table of contents, clicking Properties, then
clicking the Symbology tab. To simply change the color of a
symbol, right-click the symbol in the table of contents to display the
color palette and click any color or More Colors.
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Setting the route identifier field

Whenever route data is added to a map, ArcMap exposes some additional layer properties. One of these
properties is the Route Identifier field. The contents of this field uniquely identify each route.

Setting the Route Identifier field is not required. Doing so, however, reduces the number of steps required to
use many of the ArcMap linear referencing dialog boxes, tools, and wizards.

Steps:

1. Right-click the routeslayer in the table of contents and click Properties.
The Layer Properties dialog box opens.

2. Click the Routes tab.

3. Click the Route Identifier drop-down arrow and click Route1.

4. Click OK.

5. Repeat steps 1 through 4 for the routes_new layer.

Adding the Identify Route Locations tool

ArcMap gives you the ability to point to a route in a map and find the route identifier along with the measure
value at that location. In this part of the exercise, you will use the Identify Route Locations tool to inspect the
measures on the routes you created in exercise 2.

The Identify Route Locations tool does not appear on any toolbar by default. You will have to add it to one.

Steps:

1. Click Customize > Customize Mode.
The Customize dialog box opens.
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2. Click the Commands tab.

3. Click Linear Referencing in the Categories list.

4. Drag and drop the Identify Route Locations tool to the toolbar of your choice, such as the
Tools toolbar.

5. Click Close.

Identifying route locations

In ArcMap, a bookmark is a saved map location. A bookmark has been created for you containing some of
the calibration points used to recalibrate the routes in Exercise 2 Creating and calibrating route data.

Steps:

1. Click Bookmarks and click Calibration Points.

When ArcMap moves to the saved location, the calibration points appear with labels that
represent the measure values for each point. The reason they appear when the bookmark has
been used is because scale suppression was set on the layer.

2. Click the Identify Route Locations button.
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3. Move the pointer over one of the calibration points and click.
Route locations from both the routes and routes_new layers are identified.

4. Click the route node for each of the route layers.

The numeric value listed for each of these nodes corresponds to the value stored in the Route
Identifier field, which you set in a previous section of this exercise. Note that the measure
values for the two routes differ. Note further that the measure value for the routes_new layer
corresponds closely to the measure value of the calibration point you clicked—the closer you
are to a calibration point, the closer the measure will be.

5. Right-click the route node for one of the layers and explore the context choices available to
you.

6. Close the Identify Route Location Results window.

7. Uncheck the check box for the calibration_points layer in the table of contents to make it not
visible. It will not be used any further in this exercise.
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Finding route locations

In many linear referencing applications, you will discover that you will often need to find a location along a
route. For example, you may need to find where an accident occurred along a highway. On a paper map, it
is hard to find a route location. This is because route measures are typically not shown. In ArcMap, finding a
route location is made easy.

Steps:

1. Click the Find button on the ArcMap Tools toolbar.

2. Click the Linear Referencing tab.

3. Click the Route Reference drop-down arrow and click routes_new.

Notice that the field listed in the Route Identifier drop-down list corresponds to the Route
Identifier field you set previously in this exercise.

4. Click Load Routes.

5. Click the Route drop-down arrow and choose30000121.
This number is often a combination of many numeric fields and is meant to have no political,
social, or economic meaning, so that it will not change over time.

6. Type 5 in the Location text box.

7. Click Find.
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8. Right-click the route location that was found and explore the context choices available to you.

9. Close the Find dialog box.

Displaying route measure anomalies

In most linear referencing applications, route measure values are expected to follow a set of rules. For
example, you might expect that route measures always increase over the course of a route. ArcMap has the
ability to show you where route measures do not adhere to the behavior you expect. These are known as
route measure anomalies.

Steps:

1. Click the Full Extent button on the ArcMap Tools toolbar.

2. Right-click the routes layer in the contents and click Properties.

3. Click the Routes tab.

4. Check Show where measures do not increase.

5. Click the Line Symbol button and choose a line symbol you like. Do the same for the marker
symbol.

6. Click OK.

Linear Referencing Tutorial

Copyright © 1995-2010 Esri. All rights reserved. 18



Remember that the routes feature class was created from the base_roads feature class in
Exercise 2 Creating and calibrating route data. There are a few digitizing and attribute errors
that caused the measure anomalies to exist in the routes feature class. Route measure
anomalies can be fixed with ArcMap route editing tools.
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Exercise 4: Displaying and querying route events
In this exercise, you will create a new event table that represents where
injury accidents occurred along sections of poor-quality pavement.

To do this, you will first use the Make Route Event Layer tool to display the
accident location and pavement quality event data on your map. You will
then use the Select By Attributes dialog box to select the injury accidents
and poor-quality pavement locations. You will use the Overlay Route Events tool to create a new event table
whose records represent where injury accidents occurred along poor-quality pavement. Finally, you will add
these events to the ArcMap display.

If you have not completed Exercise 2 Creating and calibrating route data, open ArcCatalog. Within the table of
contents, delete PITT.gdb in your \MyLR folder and rename PITT_Results.gdb to PITT.gdb.

Opening an existing map document

To begin this exercise, you will start ArcMap and open an existing document.

Steps:

1. Start ArcMap by clicking Start > All Programs > ArcGIS > ArcMap 10.

2. Click File > Open.

3. Click the Look in drop-down arrow on the Open dialog box and navigate to the location where
you created the \MyLR folder.

4. Double-click Ex4.mxd.

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Goal:
Display and query route events
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The map opens.

5. Click the List by Source view in the table of contents.

This map contains the following layers in a data frame called Pitt County:

routes_hwy Shapefile copy of routes_new feature class you created in Exercise 2 Creating and
calibrating route data

county
boundary

Pitt County boundary

accident Point event table storing accident information

pavement Line event table storing pavement information

base_roads All the roads in Pitt County

Displaying point events on your map

The accident table is a point event table. Point events occur at a precise point location along a route. In this
section of the exercise, you will display the accident event data as a layer.

Steps:

1. Click Geoprocessing > Search For Tools.
The Search window opens.

2. Type Make Route Event Layer in the search box.
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3. Click Search Tools.
The Search window lists tools that are related to the search string you entered.

4. Click the Make Route Event Layer tool in the search results.

5. Click the Input Route Features drop-down arrow and click routes_hwy.

6. Click the Route Identifier Field drop-down arrow and click ROUTE1.

7. Click the Input Event Table drop-down arrow and click accident.

8. Click the Route Identifier Field drop-down arrow and click ROUTE1.

9. Click the Event Type drop-down arrow and click POINT.

10. Click the Measure Field drop-down arrow and click MEASURE.

11. Type accident Eventsin the Layer Name text box.

12. Click OK.

A new layer—accident Events—has been added to your map.
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Displaying line events on your map

The pavement table is a line event table. Line events differ from point events in that they have two measure
fields that define a portion of a route. The procedure for adding line events to your map is almost the same
as adding point events.

Steps:

1. Click Geoprocessing > Search For Tools.
The Search window opens.

2. Type Make Route Event Layer in the search box.

3. Click Search Tools.
The Search window lists tools that are related to the search string you entered.

4. Click the Make Route Event Layer tool in the search results.

5. Click the Input Route Features drop-down arrow and click routes_hwy.

6. Click the Route Identifier Field drop-down arrow and click ROUTE1.

7. Click the Input Event Table drop-down arrow and click pavement.

8. Click the Route Identifier drop-down arrow and click ROUTE1.

9. Click theEvent Type drop-down arrow and click LINE.

10. Click the From-Measure Field drop-down arrow and click BEGIN_MP.

11. Click the To-Measure Field drop-down arrow and click END_MP.

12. Type pavement Eventsin the Layer Name text box.

13. Click OK.
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A new layer—pavement Events—has been added to your map.

You might have to use the Zoom tool to zoom in on the map to see the pavement events, or you could
click and move the pavement Events layer to the top of the layer list in the table of contents.

Querying events

Layers based on an event table can be queried in many ways. They can be identified by clicking them,
selected by dragging a box or clicking them on the map, selected by clicking them in an attribute table, and
selected using a Structured Query Language (SQL) expression. You will use the Select By Attributes dialog
box to input expressions to select the event records needed for this exercise. Specifically, you will select
injury accidents and poor-quality pavement.

Steps:

1. Click Selection > Select By Attributes.
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2. Click the Layer drop-down arrow and click accident Events.

3. Scroll down and double-click NUM_INJURY in the Fields list.

4. Click the greater than operator (>).

5. Click Get Unique Values.

6. Double-click 0 in the Unique Values list.
"NUM_INJURY" > 0 is the expression that appears in the text box.

7. Click Apply.

You will see a number of the features in the accident Events layer selected in the ArcMap
display window.

8. Click the Layer drop-down arrow and click pavement Eventson the Select By Attributes
dialog box.

9. Type "RATING" < 50 in the text box.

Linear Referencing Tutorial

Copyright © 1995-2010 Esri. All rights reserved. 25



10. Click Apply.

11. Click Close.

Now both the accident and pavement events are selected on your map. To see this more clearly, you may
want to uncheck and check the accident Events and pavement Events layers in the table of contents.

In the next section of this exercise, you will use the Overlay Route Events tool to intersect the two event
layers. The result will be a table that contains the injury accidents that happened on poor-quality
pavement. All attributes from both inputs are maintained. First, however, you need to be sure that your
geoprocessing results are automatically added to your display.

Setting geoprocessing results to display automatically

Steps:

1. Click Geoprocessing > Geoprocessing Options.

2. Check Add results of geoprocessing operations to the display.
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3. Click OK.

Intersecting event layers

Steps:

1. Click Geoprocessing > Search For Tools.
The Search window opens.

2. Type Overlay Route Events in the search box.

3. Click Search Tools.
The Search window lists tools that are related to the search string you entered.

4. Click the Overlay Route Events tool in the search results.

5. Click the Input Event Table drop-down arrow and click the accident Events layer.

Note: Because you chose an event layer, the Route Identifier Field,
Event Type, and Measure Field values were set automatically. If
you had chosen an event table, you would be responsible for
setting these parameters.

6. Click the Overlay Event Table drop-down arrow and click the pavement Events layer.

7. Click the Type of Overlay drop-down arrow and click INTERSECT.
This allows you to find the intersecting event layers.

8. Type C:\MyLR\AccPav.dbf for the value of the Output Event Table parameter.

9. Keep the remaining defaults.
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10. Click OK to execute the tool.

11. The AccPav.dbf table is added to the ArcMap session. If you cannot see it in the table of
contents, click the List by Source button in the Table of Contents window.
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Displaying the intersected event results

Steps:

1. Click Geoprocessing > Search For Tools.
The Search window opens.

2. Type Make Route Event Layer in the search box.

3. Click Search Tools.
The Search window lists tools that are related to the search string you entered.

4. Click the Make Route Event Layer tool in the search results.

5. Click the Input Route Features drop-down arrow and click the routes_hwy layer.

6. Click the Route Identifier Field drop-down arrow and click ROUTE1.

7. Click the Input Event Table drop-down arrow and click AccPav.

8. Click the Route Identifier Field drop-down arrow for the event table and click ROUTE1.

9. Click OK.

The AccPav events layer is added to the contents.
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10. Uncheck the accident Events and pavement Events layers in the contents.
You see only the injury events that occurred along poor-quality pavement. Each of these new
events has all the attributes from both the accident and pavement tables.
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Exercise 5: Editing routes
There are a number of tools in ArcMap that make the interactive creation
and editing of route measures easy. In this exercise, you will create a new
route from a selected set of linear features and set its identifier. You will then
convert the measures of this newly created route from feet to miles. Last,
you will recalibrate the route using known measure values at specific
locations on your map.

If you have not completed Exercise 2, open ArcCatalog. Within the table of contents, delete PITT.gdb in your
\MyLR folder and rename PITT_Results.gdb to PITT.gdb.

Opening an existing map document

To do this exercise, you must start ArcMap.

Steps:

1. Start ArcMap by clicking Start > All Programs > ArcGIS > ArcMap 10.

2. Click File > Open.

3. Click the Look in drop-down arrow on the Open dialog box and navigate to the folder where
you installed the data for this tutorial.

4. Double-clickEx5.mxd.
The map opens.

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Goal:
Edit routes
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Adding route data to your map

You will use one of the route feature classes you created in Exercise 2: Creating and calibrating route data
to complete this exercise.

Steps:

1. Click the Add data button.

2. Click the Look in drop-down arrow and navigate to your \MyLR folder. Double-click PITT.gdb
and double-click the PITT feature dataset.

3. Click the routes_new feature class.

4. Click Add.

Adding the toolbars and editing

The toolbars necessary to complete this exercise might not be visible.

Steps:

1. Click the Editor Toolbar button to add the Editor toolbar to ArcMap.

2. Click the Editor menu, point to More Editing Tools, then click Route Editing.
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3. Click the Editor menu and click Start Editing.

Making a route from selected features

The highway authority has been informed that it will now be responsible for maintaining a road that it
previously had not been maintaining. It is necessary, therefore, to select the appropriate features from the
base_roads feature class and make a route in the routes_new feature class out of them.

The Make Route command creates a new route in the target feature layer by merging a selected set of line
features and setting the measure values. The selected line features do not need to be from the target
feature layer.

Steps:

1. Click Selection on the Main menu and click Select By Attributes.

2. Click the Layer drop-down arrow and click base_roads.

3. Type the following in the text box: "FENAME" = 'Cornerstone Row'.
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Tip: If you are clicking in the field boxes to build the expression, you
may need to click Complete List, under Unique sample values.

4. Click Apply.

5. Click Close.
Nine features from the base_roads feature layer are now selected.

6. Right-click the base_roads layer in the table of contents, point to Selection, then click Zoom
To Selected Features.

7. Right-click the base_roads feature layer and click Open Attribute Table.
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8. Click the Show Selected Records button to show only the selected records.
You can also see the total number of selected records shown along the bottom of this window.

9. Close the Attributes table.

10. Click the Make Route button on the Route Editing toolbar.

Notice routes_new is automatically specified as the feature template, because it is the only
route feature class in the map. Had there been multiple route feature classes in the map, you
could specify the appropriate template. Feature templates define all the information required to
create a new feature: the layer where a feature will be stored and the attributes new features
will be created with.

11. Click the Start Point button.
The Make Route dialog box changes and lets you know you need to pick a route starting
point.

12. Click the map near the upperright corner of the selected set of features. This is where the
output route's measures will begin.
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The program tries to assist you by circling the endpoint it will select. As you move your pointer
along the route, this point can change. This is useful because you do not need to select the
exact spot on the route; just click on the display when the correct location is circled.

13. Click Make Route on the Make Route dialog box.

The new route flashes when it is being created. During the route creation process, the selected lines are
deselected and the new route is selected. This is so you can set the new route's attributes.

Setting the route identifier

Because the newly created route is selected, you can now set the route identifier. The route identifier
uniquely identifies each route.

Steps:

1. Click the Attributes button on the Editor toolbar.

2. Click the ROUTE1 value and type 40001777.
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3. Press ENTER on your keyboard.

4. Close the Attributes window.

Converting route measure units

When you created the new route, you accepted the default method for setting the route measures. This
method accumulates the geometric length of the input line features and uses the length as the measure.
Because the coordinate system of the feature class is state plane feet, the measures on the new route are in
feet. However, the measures on all other routes in the feature class are in miles.

Steps:

1. The newly created route should still be selected. If it is not, select it.

2. Double-click the selected route feature.
The selected feature will now be loaded into the edit sketch.

3. Click the Sketch Properties button.
The Edit Sketch Properties opens.

Note the size of the measure values (in column M).
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4. Close the Edit Sketch Properties window.

5. Right-click anywhere over the edit sketch (you know you are over the line when the pointer
changes), point to Route Measure Editing, then click Apply Factor.

6. Type 0.00018939 in the Factor text box and press ENTER on the keyboard.
This converts feet to miles.

At this point, you have only made changes to the edit sketch, not the route feature.

7. Press F2 to finish the edit sketch. Alternatively, right-click anywhere over the edit sketch and
click Finish Sketch.

Your route measures are now in miles. You can verify this by double-clicking the selected route to bring it
into the edit sketch, right-clicking anywhere over the sketch, then clicking Sketch Properties. Note that
this is an alternate way to perform steps 2 and 3.

Recalibrating a route

So far in this exercise, you have created a route and transformed its measures from feet to miles. Imagine
that at some point the maintenance crew went out into the field and recorded the actual mileage for this new
route. The mileage was captured every time the new route intersected with another route from the same
feature class. In this section of the exercise, you will recalibrate the newly created route based on this
mileage information.

Steps:

1. The newly created route should still be selected. If it is not, select it.
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2. Click the Editor drop-down arrow and click Snapping > Snapping Toolbar.
This Snapping toolbar is now visible.

3. Ensure that vertex snapping is enabled and edge snapping is disabled.

4. Close the Snapping toolbar. It will not be used again in this exercise.

With the snapping environment set, you will be able to create calibration points that are
snapped to the end vertex of the features in the routes_new layer, thereby ensuring accuracy of
the route measures at the calibration points. Setting the snapping environment, however, is not
necessary for the Calibrate Route tool to work.

5. Click the Calibrate Route button on the Route Editing toolbar.
The Calibrate Route dialog box is now on the screen, but it is empty. Your next task is to
digitize the calibration points.

6. With the Calibrate Route dialog box open, click the Add Calibration Pointstool.

7. Click along the route at nine different places to create the calibration points. The locations of
the calibration points are indicated in the graphic below.

8. Enter the new m-values (see values in graphic below) for each calibration point by clicking
each value in the column and typing the new value.

9. Click Calibrate Route.
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Saving your edits

Once you have completed the steps in this exercise, you can choose to save or discard your edits by
stopping the edit session.

Steps:

1. Click the Editor menu and click Stop Editing.

2. Click Yes to save your edits.

In this exercise, you first learned how to create a route from a selected set of line features. Next, you
converted the route measures from feet to miles. Last, you learned how to recalibrate a route using calibration
points you digitized on the map.
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