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About the Data Interoperability extension tutorial
The Data Interoperability extension tutorial introduces you to the tools and functionality that are available in
ArcGIS when the extension is enabled. It is divided into three sections that guide you through direct-read
formats and interoperability connections, quick conversion tools, and the fundamentals of transforming data
using FME Workbench.

The exercises within each section demonstrate concepts and methods sequentially and therefore should be
completed in the order they are presented. They are designed to allow you to work at your own pace without
additional assistance using ESRI ArcTutor sample data.

You will need about 30–40 minutes of focused time to complete all the exercises.

Tutorial data

This tutorial assumes you have installed the ESRI ArcTutor data at C:\arcgis\ArcTutor\Data Interoperability.
If not, make the appropriate path changes throughout this tutorial. Ask your system administrator for the
correct path to the tutorial data if you do not find it at the default installation path.

Using direct-read formats and connections

• In Exercise 1a: Using direct-read formats, you work directly with a MapInfo TAB dataset in ArcMap.

• In Exercise 1b: Adding interoperability connections, you create and work with an interoperability
connection for Intergraph Modular GIS Environment (MGE) data.

Translating data with the quick conversion tools

• In Exercise 2a: Importing data with the Quick Import tool, you import Geography Markup Language
(GML) zoning data using the Quick Import tool.

• In Exercise 2b: Exporting data with the Quick Export tool, you export geodatabase zoning data to a
MapInfo TAB dataset using the Quick Export tool.

• In Exercise 2c: Automating quick conversion tools with ModelBuilder, you create a model that
imports GML zoning data, aggregates features based on specific attributes, and exports the results
to GML and MapInfo TAB datasets.

Transforming data with spatial ETL tools

• In Exercise 3a: Getting started with spatial ETL, you create a simple spatial ETL tool that reads
Intergraph Modular GIS Environment (MGE) parcel data and loads it into a geodatabase.

• In Exercise 3b: Transforming data and using Visualizer, you learn the fundamentals of using FME
transformers by adding them to the spatial ETL tool you created in "Getting started with spatial ETL."

• In Exercise 3c: Using source attributes to separate data, you learn how to use spatial ETL to
categorize data and generate sets of features with common values.
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Exercise 1a: Using direct-read formats
Direct-read formats are used directly from the Catalog tree as read-only
datasets. When you add them to ArcMap, ArcScene, or ArcGlobe, all
standard map functions are enabled, including attribute tables and labeling
functions.

Using a direct-read feature class in ArcMap is similar to working with other
geodatabase feature classes. You can snap to geometry, substitute
symbology, query attributes, and use it with all geoprocessing tools that
accept feature classes or layers as input.

This exercise introduces you to direct-read formats using MapInfo TAB data; other formats supported by the
Data Interoperability extension can be used in the same way.

Add the data to ArcMap

Prerequisite:
The Data Interoperability extension must be enabled.

Steps:

1. Start ArcMap.

2. Click the Catalog Window button on the Standard toolbar.

3. Type C:\arcgis\ArcTutor\Data Interoperability\ in the Location text box and
press ENTER.
The location is added to the Catalog tree under the Folders Connections heading.

4. Click the subdivisions.tab dataset and drag it into your map.
ArcGIS uses spatial indexes to quickly locate features in feature classes. Notice that ArcGIS
indexes the dataset the first time you add it to ArcMap and displays a status window. The
display duration of the window depends on the size of the dataset; the window may be
displayed only for a few seconds for small datasets.

5. Right-click the subdivisions Line feature layer and click Open Attribute Table.
The feature layer contains no data. Repeat this step for other feature layers and observe that
only the Polygon feature layer contains data.

6. Right-click the folder in the table of contents and click Remove.
The dataset is removed from ArcMap.

Unlike a native ESRI dataset, when you connect to a MapInfo TAB dataset for the first time, it generates a
feature class entry for all geometries supported by the format; other nonnative formats produce similar
results. The next section will show you how to purge empty feature classes from the dataset.

Purge the empty feature classes

To purge empty feature classes from the dataset, refresh the dataset in the Catalog tree.

Steps:

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\arcgis\ArcTutor\Data Interoperability\

Goal:
Learn how to work with nonnative
datasets in ArcMap when the Data
Interoperability extension is enabled.
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1. Click the subdivisions.tab dataset in the Catalog window.

2. Press F5 to refresh the data, or right-click the dataset and click Refresh.

3. Expand the dataset in the Catalog tree.
Only the subdivision Polygon feature layer is displayed.

Explore the dataset

Explore the dataset in ArcMap and the Catalog window to gain insight about working with nonnative data
formats when the Data Interoperability extension is enabled.

Steps:

1. Right-click the subdivision Polygon feature class in the Catalog tree, and click Item Properties
from the shortcut menu.

2. Click the Description tab and explore the metadata.

3. Drag the subdivision Polygon feature class into ArcMap.

4. Click the Identify button and select a feature to view the attributes.

This completes the exercise.

Continue to the next exercise: Exercise 1b: Adding interoperability connections.
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Exercise 1b: Adding interoperability connections
Interoperability connections can be used to aggregate files, perform
translations on the fly, define a coordinate system, and store format-specific
parameters such as database connections and passwords. All
interoperability connections are saved in the Interoperability Connections
folder.

In this exercise, you create an interoperability connection for Intergraph
Modular GIS Environment (MGE) parcel data.

The MGE format uses standard MicroStation DGN files to store and edit the graphic elements of geographic
data. The nongraphic elements, such as feature attributes, are stored in external database tables and linked to
the graphic elements via pairs of entity and mslink numbers.

Using the Add Interoperability Connection dialog box, you perform the following tasks:
• Choose the FME reader and specify the data source.

• Specify the reader parameters for the external database.

• Define a coordinate system.

• Create the connection.

After creating the connection, you add the dataset to ArcMap, change symbology, and select features by
attributes.

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\arcgis\ArcTutor\Data Interoperability\

Goal:
Create an interoperability connection.
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Create the interoperability connection

Opening the Interoperability Connection dialog box

Prerequisite:
The Data Interoperability extension must be enabled.

Steps:

1. Start ArcMap.

2. Click the Catalog Window button on the Standard toolbar.

3. Expand the Interoperability Connections folder.

4. Double-click Add Interoperability Connection.
The Interoperability Connection dialog box opens.

Choosing the FME reader

Steps:

1. Click the Format browse button.
The FME Reader Gallery dialog box opens.

2. Type mge in the Search text box.

3. Click the row listing the Intergraph MGE format.

4. Click OK.
The FME Reader Gallery dialog box closes and the Format text box is populated with the
format description.
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Specifying the data source

Steps:

1. Click the Dataset browse button.
The Select File dialog box opens.

2. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\parcels folder.

3. Click the File Type arrow and choose All Files (*.).
The files with a .par file extension are displayed in the dialog box.

Note: The MicroStation DGN format permits files to be saved without
a file extension or with an extension of any length. As a result, it
is not uncommon for DGN files to be saved with an extension
that describes the contents. This tutorial uses the .par extension
to identify them as parcel drawings.

4. Click the parcel_K24.par file and click Open.
The Dataset text box is populated with the path and file name.

Specifying the reader parameters

Specify the external database that contains the attribute tables.

Steps:

1. Click the Parameters button.
The Intergraph MGE Parameters dialog box opens.

2. Click the Database Type arrow and choose MDB.

3. Click the Access MDB File browse button.

4. Navigate to C:\arcgis\ArcTutor\Data Interoperability\parcels\parcel_attrs.mdb and click
Open.

5. Click OK.
The Intergraph MGE Parameters dialog box closes.
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Defining a coordinate system

Steps:

1. Click the Coordinate System browse button.
The Spatial Reference Properties dialog box opens.

2. Click Select.

3. Double-click the Projected Coordinate Systems folder, double-click the State Plane folder,
double-click the NAD 1983 (US Feet) folder, choose NAD 1983 StatePlane Texas Central
FIPS 4203 (Feet).prj, then click Add.

4. Click OK.
The Spatial Reference Properties dialog box closes.

Creating and preparing the connection

Steps:

1. Click OK in the Interoperability Connection dialog box.
The Interoperability Connection dialog box closes, and an interoperability connection
named Connection (1)—parcel_K24 MGE is added to the Interoperability Connections
folder.

2. Right-click the dataset, click Rename, then rename it to parcel K24.

3. Expand the parcel K24 dataset in the Catalog tree.
The dataset displays several feature classes that are potentially empty and not needed.

4. Click the parcel K24 dataset and press F5 to purge any empty feature classes.

5. Expand the parcel K24 dataset and confirm your results.
The dataset contains only two feature classes.

Add data to ArcMap

Add the interoperability connection for the MGE parcel K24 dataset to ArcMap. Also add the MapInfo
subdivisions.tab dataset, and the MapInfo flood_plains.mif dataset.

Steps:

1. Drag the parcel K24 dataset into ArcMap.

2. In the Catalog window, type C:\arcgis\ArcTutor\Data Interoperability in the
Location text box and press ENTER.
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The location is added to the Catalog tree under the Folders Connection heading.

3. Expand the flood_plains.mif dataset and drag the flood_plains Polygon feature class into
ArcMap.

4. Expand the subdivisions.tab dataset and drag the subdivisions Polygon feature class into
ArcMap.

Change the symbology

Assign a unique symbol for each date a subdivision was added to the survey. Use the ADD_DATE field.
Also, set MapTips to display the contents of the SUBDIVISION field when pausing the pointer over a
subdivision.

Steps:

1. Right-click the subdivisions Polygon layer and click Properties.
The Layer Properties dialog box opens.

2. Click the Display tab.

3. In the Display Expression box, click the Fields arrow and choose the SUBDIVISION field.

4. Check the box Show MapTips using the display expression.

5. Click the Symbology tab.

6. Click Categories and click Unique values.

7. Click the Value Field arrow and choose the ADD_DATE field.

8. Click the Add all Values button.
A unique symbol is generated for each unique value in the field.

9. Click OK.
The Layer Properties dialog box closes.

10. Right-click the subdivisions Polygon layer in the table of contents and click Zoom to Layer.

11. Pause the pointer over the subdivisions to see the names displayed as MapTips.

Select by attributes

Search for Gaston Park and zoom to it.

Steps:

1. On the main menu, click Selection > Select By Attributes .
The Select by Attributes dialog box opens.

2. Click the Layer arrow and choose the subdivisions Polygon feature layer.

3. Double-click the SUBDIVISION field.
The field name is added to the expression box.

4. Click the Like button and press the SPACEBAR once to add a space after the word.

5. Type 'GAS%' to complete the SQL statement.
The completed expression should read "SUBDIVISION" LIKE 'GAS%'.
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6. Click the Apply button.
The selected features are highlighted in the map.

7. Click the OK button.
The Select by Attributes dialog box closes.

8. On the main menu, click Selection > Zoom To Select Features .

9. Pause the pointer over the selected feature to display the name GASTON PARK as a MapTip.

This completes the exercise.

Continue to the next exercise: Exercise 2a: Importing data with the Quick Import tool.
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Exercise 2a: Importing data with the Quick Import tool
The Quick Import tool converts any data source supported by the Data
Interoperability extension and loads it into a geodatabase using a simple
one-to-one translation. This tool is ideal for importing nonnative data when
your workflow does not require feature geometry or schema to be modified.

In this exercise, you import Geography Markup Language (GML) zoning
data.

Using the Quick Import dialog box, you perform the following tasks:
• Choose the FME reader and specify the data source.

• Accept the default reader parameters.

• Accept the coordinate system defined by the data source.

• Specify the destination staging geodatabase.

• Import the data.

After importing the data, you add the dataset to ArcMap to verify your results.

Open the tool and specify input

Prerequisite:
The Data Interoperability extension must be enabled.

Steps:

1. Start ArcMap.

2. Click the Catalog Window button on the Standard toolbar.

3. Find and open the Quick Import tool using the Search window .

4. Click the Input Dataset browse button.
The Specify Data Source dialog box opens.

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\arcgis\ArcTutor\Data Interoperability\

Goal:
Import GML data using the Quick Import
tool.
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Choosing the FME reader

Steps:

1. Click the Format browse button.
The FME Reader Gallery dialog box opens.

2. Type gml in the Search text box.

3. Click the row listing Geography Markup Language (GML) and click OK.
The FME Reader Gallery dialog box closes.

Specifying the data source

Steps:

1. Click the Dataset browse button.
The Select File dialog box opens.

2. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\zoning folder.

3. Click the zoning.gml dataset and click Open.
The Dataset text box is populated with the path and file name.

Caution: Some file extensions can be associated with more than one
format. It is good practice to visually confirm that the format and
file extension are correctly matched before closing the dialog box.

4. Click OK.
The Specify Data Source dialog box closes.
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Specify the output geodatabase and run the tool

The Quick Import tool creates a geodatabase as output. The output staging geodatabase can be used
directly or for further processing.

Steps:

1. Click the Output Staging Geodatabase browse button, navigate to the
C:\arcgis\ArcTutor\Data Interoperability\zoning folder, type zoning in the Name text box, then
click Save.
The Output Staging Geodatabase text box is populated with the path and name.

2. Click OK.
The tool executes the conversion in the background. A progress bar at the bottom of your map
displays the name of the tool. When the tool is finished, a pop-up notification appears in the
system tray. You can examine the details of the conversion in the Results window.

Add the data to ArcMap

Steps:

1. Type C:\arcgis\ArcTutor\Data Interoperability\zoning\zoning.gdb in the
Location text box and press ENTER.
The location is added to the Catalog tree under the Folders Connection heading.

2. Drag the zoning feature class into ArcMap and verify your results.
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This completes the exercise.

Continue to the next exercise: Exercise 2b: Exporting data with the Quick Export tool.
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Exercise 2b: Exporting data with the Quick Export tool
The Quick Export tool converts geodatabase feature classes or feature
layers to any external dataset supported by the Data Interoperability
extension using a simple one-to-one translation. This tool is ideal for
exporting data to nonnative datasets when your workflow does not require
feature geometry or schema to be modified.

In this exercise, you export geodatabase zoning data to a MapInfo TAB
dataset.

Using the Quick Export dialog box, you perform the following tasks:
• Specify the geodatabase data source.

• Choose the FME writer and specify the data destination.

• Accept the default writer parameters.

• Accept the coordinate system defined by the data source.

• Export the data.

After exporting the data, you add the dataset to ArcMap to verify your results.

Open the tool and specify input

Prerequisite:
The Data Interoperability extension must be enabled.

Before starting this exercise, you must have completed the previous exercise, Exercise 2a: Importing data
with the Quick Import tool.

Steps:

1. Start ArcMap.

2. Click the Catalog Window button on the Standard toolbar.

3. Find and open the Quick Export tool using the Search window .

4. Type C:\arcgis\ArcTutor\Data Interoperability\zoning\zoning.gdb in the
Location text box and press ENTER.
The location is added to the Catalog tree under the Folders Connection heading.

5. Drag the zoning feature class into the Input Features text box.

Complexity:
Beginner

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\arcgis\ArcTutor\Data Interoperability\

Goal:
Export geodatabase data to a MapInfo
TAB dataset using the Quick Export tool.
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Specify the output and run the tool

Steps:

1. Click the Output Dataset browse button.
The Specify Data Destination dialog box opens.

Choosing the FME writer

Steps:

1. Click the Format browse button.
The FME Writer Gallery dialog box opens.

2. Type tab in the Search text box.

3. Click the row listing MapInfo TAB (MITAB) and click OK.
The FME Writer Gallery dialog box closes.
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Specifying the data destination and running the tool

Steps:

1. Click the Dataset browse button.
The Select Folder dialog box opens.

2. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\zoning folder and click Open.
The Select Folder dialog box closes and the Dataset text box is populated with the path. By
default, the MapInfo TAB writer uses the input feature class name.

3. Click OK.
The Specify Data Destination dialog box closes.

4. Click OK.
The tool executes the conversion in the background. A progress bar at the bottom of your
map displays the name of the tool. When the tool is finished, a pop-up notification appears in
the system tray. You can examine the details of the conversion in the Results window.

Add the data to ArcMap

Steps:

1. Click the zoning folder and press F5 to refresh the contents.

2. Expand the new zoning.tab dataset in the Catalog window.

3. Drag the zoning Polygon feature class into ArcMap and verify your results.
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This completes the exercise.

Continue to the next exercise: Exercise 2c: Automating quick conversion tools with ModelBuilder.
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Exercise 2c: Automating quick conversion tools with
ModelBuilder
The Data Interoperability quick conversion tools can be used in ModelBuilder
and connected to other geoprocessing tools to automate conversion
workflows.

In this exercise, you build a model that performs the following tasks:
• Imports geodatabase zoning data

• Aggregates the polygons and removes grid tiles

• Exports the results to GML and MapInfo TAB formats

Create a toolbox and a model

Prerequisite:
The Data Interoperability extension must be enabled.

Steps:

1. Start ArcMap.

2. Click the Catalog Window button on the Standard toolbar.

3. Type C:\arcgis\ArcTutor\Data Interoperability\zoning\ in the Location text
box and press ENTER.
The location is added to the Catalog tree under the Folders Connection heading.

4. Right-click the zoning folder and click New > Toolbox .

5. Right-click the toolbox, click Rename, then name it zoning.

6. Right-click the zoning toolbox and click New > Model .
ModelBuilder opens.

Tip: By default, the model is named Model. You can rename it by
right-clicking it in the Catalog window and clicking Rename from
the shortcut menu.

Complexity:
Intermediate

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\arcgis\ArcTutor\Data Interoperability\

Goal:
Automate the execution of quick
conversion tools using ModelBuilder.
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Add the Quick Import tool

Steps:

1. Find the Quick Import tool using the Search window and drag it onto the ModelBuilder
canvas.

2. Double-click Quick Import.

3. Click the Input Dataset browse button.
The Specify Data Source dialog box opens.

Choosing the FME reader

Steps:

1. Click the Format browse button.
The FME Reader Gallery dialog box opens.

2. Type gml in the Search text box.

3. Click the row listing Geography Markup Language (GML) and click OK.
The FME Reader Gallery dialog box closes.

Data Interoperability Extension Tutorial

Copyright © 1995-2010 Esri. All rights reserved. 21

http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//001600000005000000


Specifying the data source

Steps:

1. Click the Dataset browse button.
The Select File dialog box opens.

2. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\zoning folder.

3. Click the zoning.gml dataset and click Open.
The Dataset text box is populated with the path and file name.

Caution: Some file extensions can be associated with more than one
format. It is good practice to visually confirm that the format and
file extension are correctly matched before closing the dialog box.

4. Click OK.
The Specify Data Source dialog box closes.

Specifying the destination geodatabase

Steps:

1. Click the Output Staging Geodatabase browse button, navigate to the
C:\arcgis\ArcTutor\Data Interoperability\zoning folder, type zoning2 in the Name text box,
then click Save.
The Output Staging Geodatabase text box is populated with the path and name. In the
following section, you connect this output as input to the Select Data tool.

2. Click OK.
The Quick Import dialog box closes and displays the tool in a ready-to-run state.

Add the Select Data tool

Use the Select Data tool to select the zoning feature class contained in the zoning2.gdb geodatabase.

Steps:

1. Find the Select Data (ModelBuilder) tool using the Search window and drag it onto the
ModelBuilder canvas.

2. Click the Connect button on the toolbar.

3. Click zoning2.gdb, click Select Data, then click Input Data Element on the shortcut menu.
The output geodatabase zoning2.gdb is connected as input to the Select Data tool.

Data Interoperability Extension Tutorial

Copyright © 1995-2010 Esri. All rights reserved. 22

http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//0017000000v6000000


4. Double-click Select Data and confirm that the Child Data Element text box is set to zoning.

The child data element is the feature class contained in the zoning2.gdb output geodatabase
that will be used as input to the Dissolve tool.

5. Click OK.
This closes the Select Data dialog box.

Add the Dissolve tool

Steps:

1. Find the Dissolve tool using the Search window and drag it onto the ModelBuilder canvas.

2. Click the Connect button on the toolbar.

3. Click Output data element, click Dissolve, then click Input Features from the shortcut menu.
The output data element is connected as input to the Dissolve tool.

4. Double-click Dissolve to open the dialog box.

5. Click the Output Feature Class browse button.
The Output Feature Class dialog box opens.

6. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\zoning folder, type
zoning_dissolve in the Name text box, then click Save.
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The Output Feature Class dialog box closes and the Output Feature Class text box is
populated with the path and file name. By default, the tool adds the (.shp) file extension.

7. Check the type check box in the Dissolve_Field(s) list.
Features with the same values for checked fields are aggregated (dissolved) into a single
feature. The dissolve fields are written to the output feature class.

8. Click OK.
The Dissolve dialog box closes.

9. Click Model > Save.

Run the model

The model generates a shapefile. During execution, the status window appears and displays a processing
log.

Steps:

1. Click the Run button .
All the tools in a ready-to-run state are executed.

2. Click Close on the status message when the model finishes executing.

3. On the ModelBuilder canvas, right-click zoning_dissolve.shp and click Add To Display from
the shortcut menu.
The results of the tool are displayed in ArcMap.
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4. Right-click the zoning_dissolve feature layer in the table of contents and click Open Attribute
Table on the shortcut menu.
The features with the same type field values are aggregated.

5. Close the attribute table.

6. Right-click the original zoning feature class in the Catalog window, click Item Properties on
the shortcut menu, then click the Preview tab.
Compare your results and notice that the Dissolve tool removed the grid tiles.

7. On the canvas, right-click zoning_dissolve.shp and click Add To Display from the shortcut
menu.
The results are removed from ArcMap.

Add the Quick Export tool

Add the Quick Export tool to generate a Geography Markup Language (GML) dataset.

Steps:

1. Find the Quick Export tool using the Search window and drag it onto the ModelBuilder
canvas.

2. Right-click Output Dataset, click Rename from the shortcut menu, then type Output GML
Dataset.

3. Click the Connect button on the toolbar.

4. Click zoning_dissolve.shp, click Quick Export, then click Input Layer on the shortcut menu.

The output zoning_dissolve.shp file is connected to the Quick Export input.
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5. Double-click Quick Export.

6. Click the Output Dataset browse button.
The Specify Data Destination dialog box opens.

Choosing the FME writer

Steps:

1. Click the Format browse button.
The FME Writer Gallery dialog box opens.

2. Type gml in the Search text box.

3. Click the row listing Geography Markup Language (GML) and click OK.
The FME Writer Gallery dialog box closes.
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Specifying the data destination

Steps:

1. Click the Dataset browse button.
The Select File dialog box opens.

2. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\zoning folder, type zoning_output
in the File name text box, then click Save.
The Select File dialog box closes and the Dataset text box is populated with the path and
file name.

3. Click OK.
The Specify Data Destination dialog box closes.

Add a second Quick Export tool

Add another instance of the Quick Export tool to generate a MapInfo TAB dataset.

Steps:

1. Find the Quick Export tool using the Search window and drag it onto the ModelBuilder
canvas.

2. Right-click Output Dataset, click Rename from the shortcut menu, and type Output TAB
Dataset.

3. Click the Connect button on the toolbar.

4. Click zoning_dissolve.shp, click Quick Export (2), then click Input Layer on the shortcut
menu.

The output zoning_dissolve.shp is connected to the Quick Export (2) input.

Data Interoperability Extension Tutorial

Copyright © 1995-2010 Esri. All rights reserved. 27

http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//001600000004000000


5. Double-click Quick Export (2).

6. Click the Output Dataset browse button.
The Specify Data Destination dialog box opens.

Choosing the FME writer

Steps:

1. Click the Format browse button.
The FME Writer Gallery dialog box opens.

2. Type tab in the Search text box.

3. Click the row listing MapInfo TAB (MITAB) and click OK.
The FME Writer Gallery dialog box closes.
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Specifying the data destination

Steps:

1. Click the Dataset browse button.
The Select Folder dialog box opens.

2. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\zoning folder and click Open.
The Select Folder dialog box closes and the Dataset text box is populated with the path. By
default, the MapInfo TAB writer uses the input feature class name.

3. Click OK.
The Specify Data Destination dialog box closes.

4. Click Model > Save.

Run the model and explore the results

Steps:

1. On the main menu, click Model > Run Entire Model.
The model creates a zoning_dissolve.tab dataset and a zoning_output.gml dataset. During
execution, the Model status window appears and displays a processing log.

2. Click Close on the status window when the model is finished.

3. In the Catalog window, navigate to the C:\arcgis\ArcTutor\Data Interoperability\zoning folder.

4. Expand the zoning_dissolve.tab dataset, right-click the zoning Polygon feature class, then click
Item Description on the shortcut menu.
Preview the image and explore the metadata.

5. Expand the zoning_output.gml dataset, right-click the zoning_dissolve Polygon feature class,
then click Item Description on the shortcut menu.
Preview the image and explore the metadata.

This completes the exercise.

Continue to the next exercise: Exercise 3a: Getting started with spatial ETL.
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Exercise 3a: Getting started with spatial ETL
Spatial ETL tools are capable of a wide range of processes and dataflows
from simple format translations to complex transformations that restructure
geometry and attributes.

In this exercise, you create a simple spatial ETL tool that extracts Intergraph
Modular GIS Environment (MGE) parcel data and loads it into a
geodatabase.

The MGE format uses standard MicroStation DGN files to store and edit the
graphic elements of geographic data. The nongraphic elements, such as feature attributes, are stored in
external database tables and linked to the graphic elements via pairs of entity and mslink numbers.

You begin by using the Create Translation Workspace Wizard to perform the following tasks:
• Choose the FME reader and specify multiple data sources.

• Specify the reader parameters for the external database.

• Choose the FME writer and start FME Workbench.

Using FME Workbench, you perform the following tasks:
• Prune the workspace so that it only processes the point and line features.

• Edit the destination parameter so that the path defaults to the tutorial folder.

• Save the workspace and close Workbench.

• Open and run the spatial ETL tool from the Catalog window.

After running the tool and generating the data, you add the dataset to ArcMap to verify your results.

Create a toolbox

Prerequisite:
The Data Interoperability extension must be enabled.

Steps:

1. Start ArcMap.

2. Click the Catalog Window button on the Standard toolbar.

3. Type C:\arcgis\ArcTutor\Data Interoperability\parcels\ in the Location text
box and press ENTER.
The location is added to the Catalog tree under the Folders Connection heading.

Complexity:
Intermediate

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\arcgis\ArcTutor\Data Interoperability\

Goal:
Create a simple spatial ETL tool that
reads MGE parcel data and loads it into a
geodatabase.
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4. Right-click the parcels folder and click New > Toolbox .

5. Right-click the toolbox, click Rename, then name it parcels.

Create the translation workspace

Starting the Create Translation Workspace Wizard

Steps:

1. Right-click the parcels toolbox and click New > Spatial ETL Tool.
The Create Translation Workspace Wizard opens.
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Choosing the FME reader

Steps:

1. Click the Format browse button.
The FME Reader Gallery dialog box opens.

2. Type mge in the Search text box.

3. Click the row listing the Intergraph MGE format and click OK.
The FME Reader Gallery dialog box closes.

4. Click Next.
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Specifying the data source

Steps:

1. Click the Add (+) button.
The Select Multiple Datasets dialog box opens.

2. Click the Add Directories button.
A second navigation window opens.

3. Navigate to C:\arcgis\ArcTutor\Data Interoperability\parcels\ and click
Open.
The Select Multiple Datasets dialog box is populated with the path and the standard (.dgn
and .cad) file extensions defined for the Intergraph MGE format by FME Reader Gallery.
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Specifying the file filter parameters

The next four steps edit the default File/Filter parameters to select the MicroStation DGN (.par) drawing
files used in this exercise.

Steps:

1. Double-click the File/Filter field containing *.dgn and replace the contents with *.par.

2. Click the row specifying *.cad and click Remove.

3. Click OK.
The Select Multiple Datasets dialog box closes.

4. Click Next.

Specifying the reader parameters

Specify the external database that contains the attribute tables.

Steps:

1. Click the Parameters button.
The Intergraph MGE Parameters dialog box opens.

2. Click the Database Type arrow and choose MDB.

3. Click the Access MDB File browse button.

4. Navigate to C:\arcgis\ArcTutor\Data Interoperability\parcels\parcel_attrs.mdb and click
Open.

5. Click OK.
The Intergraph MGE Parameters dialog box closes.

6. Click Next.
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Choosing the FME writer

Steps:

1. Click the Format browse button.
The FME Writer Gallery dialog box opens.

2. Type gdb in the Search text box.

3. Click the row listing ESRI Geodatabase (File-based) and click OK.
The FME Writer Gallery dialog box closes.

4. Click Next.

Specifying the writer parameters

Accept the default parameters for the geodatabase.

Steps:

1. Click Next.

Creating the workspace

Steps:

1. Click Finish.
The wizard processes the information and starts Workbench.

Prepare the tool

Workbench opens the workspace with an ETL model of the information you provided. Prune the workspace
so that it only processes point and line features.
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Modifying the model

Steps:

1. Right-click the source feature type named unlinked and click Delete from the shortcut
menu.

2. Right-click its orphaned geometry filter and click Delete from the shortcut menu.
You may need to drag GeometryFilter_3 out of your way.

3. Click and drag to create a selection box around the remaining orphaned destination feature
types, right-click the selection, then click Delete from the shortcut menu.

4. Delete all destination feature types except for source feature types LOT_LINES and
LOT_POINTS.
The LOT_LINES source feature type LINE attribute is mapped to the LOT_LINES_line
destination feature type, and the LOT_POINTS source feature type POINT attribute is
mapped to the LOT_POINTS_point destination feature type.
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Editing the destination parameter

Specify the default output geodatabase path and file.

Steps:

1. Confirm that Navigator is available.
To open the Navigator window from the main menu, click View > Windows > Navigator.

2. Expand Published Parameters.

3. Double-click Destination ESRI Geodatabase (File-based).
The Edit Published Parameter dialog box opens.

4. Click the browse button.
The Select Destination ESRI Geodatabase (File-based) File dialog box opens.

5. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\parcels folder.

6. Type parcels_ETL.gdb in the Geodatabase text box to complete the path and click
Open.

7. Click OK.
The Edit Published Parameter dialog box closes.

Save and rename the tool

Steps:

1. Click File > Save to save the tool.

2. Click File > Exit to exit Workbench.

3. Right-click the new spatial ETL tool in the Catalog window, click Rename, then type Import
MGE Parcels.
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Open and run the tool

Steps:

1. In the Catalog window, expand the Parcels toolbox .

2. Double-click the Import MGE Parcels tool.
The spatial ETL tool Import MGE Parcels dialog box opens.

3. Click OK.
The tool executes the conversion in the background. A progress bar at the bottom of your map
displays the name of the tool. When the tool is finished, a pop-up notification appears in the
system tray. You can examine the details of the conversion in the Results window.

Add the data to ArcMap

Steps:

1. In the Catalog window, expand the parcels_ETL geodatabase and drag the feature classes
LOT_POINTS_point and LOT_LINES_line into ArcMap and verify your results.
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This completes the exercise.

Continue to the next exercise: Exercise 3b: Transforming data and verifying output.
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Exercise 3b: Transforming data and using Visualizer
A transformer is an FME Workbench object that performs a particular
restructuring of features or schema. It is a visual object that you add to your
workspace canvas and connect between the source and destination
features, or to other transformers.

This exercise introduces you to the fundamentals of using FME
transformers. You create a spatial ETL tool that transforms MGE parcel
data, evaluates the new features with a test clause, and generates output as
failed or passed features. Finally, you inspect the output of your workspace
without generating data using Visualizer. You complete the exercise by exporting the workspace as a custom
format.

Using FME Workbench, you perform the following tasks:
• Add an AreaBuilder transformer to create polygons from the LOT_LINES source feature type.

• Add a PointOnAreaOverlayer transformer to overlay the LOT_POINTS features onto the polygon
features and merge their attributes.

• Add a Tester transformer to evaluate and count the point features inside each polygon feature.

• Redirect the output of the workspace to Visualizer and inspect the output of your workspace.

• Export the workspace as a custom format.

Start ArcMap

Prerequisite:
The Data Interoperability extension must be enabled.

Before starting this exercise, you must have completed the previous exercise, Exercise 3a: Getting started
with spatial ETL.

Steps:

1. Start ArcMap.

2. Click the Catalog Window button on the Standard toolbar.

3. Type C:\arcgis\ArcTutor\Data Interoperability\parcels\ in the Location text
box and press ENTER.
The location is added to the Catalog tree under the Folders Connection heading.

Complexity:
Advanced

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\arcgis\ArcTutor\Data Interoperability\

Goal:
Learn the fundamentals of transforming
features and attributes in FME
Workbench and using Visualizer to verify
output.
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Copy and rename the spatial ETL tool

Steps:

1. Right-click the Import MGE Parcel tool and click Copy on the shortcut menu.

2. Right-click the Parcels toolbox and click Paste on the shortcut menu.

3. Right-click the Import MGE Parcel (2) tool, click Rename on the shortcut menu, then type
Custom Parcels.

4. Right-click the Custom Parcels tool and click Edit.
Workbench starts.

Add an AreaBuilder transformer

The AreaBuilder transformer creates topologically correct polygon features from lines that form closed
shapes.

Connect an AreaBuilder transformer to the LOT_LINES GeometryFilter.

Steps:

1. Confirm that Transformer Gallery is available.
To open the Transformer window from the main menu, click View > Windows > Transformer
Gallery.
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2. In the Transformers window, type areabuilder in the search text box and press ENTER.

3. Double-click AreaBuilder.
An AreaBuilder transformer is added to the canvas.

4. Click the line connecting the LOT_LINES GeometryFilter and the LOT_LINES destination
feature and press DELETE.
The GeometryFilter is disconnected from the destination feature type.

5. On the LOT_LINES GeometryFilter, click the yellow arrow beside the LINE attribute output and
drag the arrow to the red arrow beside the AreaBuilder input.
The GeometryFilter output is connected to the AreaBuilder input, and the arrow turns green.

Add a PointOnAreaOverlayer transformer

The PointOnAreaOverlayer transformer overlays point features onto area features and merges their
attributes. As a result, each polygon feature acquires attributes from the point feature contained within its
boundary. Attributes with the same name are not replaced.

Connect a PointOnAreaOverlayer transformer to the LOT_LINES AreaBuilder transformer and the
LOT_POINTS GeometryFilter.

Steps:

1. In the Transformers window, type PointOnArea in the search text box and press ENTER.

2. Double-click PointOnAreaOverlayer.
A PointOnAreaOverlayer transformer is added to the canvas.

3. Click the Properties button and view the parameters.
The PointOnAreaOverlayer Parameters dialog box opens.
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Overlap Count Attribute counts the number of point features contained in each polygon. This
is useful for validating data and sending features to separate outputs for further processing. In
the next section, you will connect a Tester transformer to evaluate this number and direct
output accordingly.

4. Click OK.
The PointOnAreaOverlayer Parameters dialog box closes.

5. Click the line connecting the LOT_POINTS GeometryFilter and the LOT_POINTS destination
feature type and press DELETE.
The GeometryFilter is disconnected from the destination feature type.

6. On the LOT_POINTS GeometryFilter, click the yellow arrow beside the POINT output and
drag the line to the red arrow beside the PointOnAreaOverlayer POINT input.
The GeometryFilter POINT output is connected to the PointOnAreaOverlayer POINT input,
and the arrow turns green.
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Organizing the canvas layout

At this time, the connectors may begin to cross over each other and appear confusing. There are several
ways to organize the canvas layout:

• Click Tools > Auto Layout, then drag the objects on the canvas.

• Right-click a connector line, click Insert Vertex on link on the shortcut menu to add one more
vertex, then drag each vertex to route the connector around other transformers.

Add a Tester transformer

The Tester transformer evaluates one or more tests on a feature and routes the feature according to the
outcome of the test(s).

Connect a Tester transformer to the PointOnAreaOverlayer transformer. Add a test clause that evaluates
the Overlap Count attribute generated by the PointOnAreaOverlayer transformer. Send polygon features
containing one point feature to the PASSED output and all others to the FAILED output.

Steps:

1. In the Transformers window, type Tester in the search text box and click Find.

2. Double-click Tester.
A Tester transformer is added to the canvas.

3. Connect the PointOnAreaOverlayer AREA output to the Test INPUT.

Data Interoperability Extension Tutorial

Copyright © 1995-2010 Esri. All rights reserved. 44



4. Click the Properties button on the Tester transformer.
The Tester Parameters dialog box opens.

5. Double-click the first cell in the Left Value field, click the down arrow, then choose _overlaps.

6. Double-click the first cell in the Op. field, click the arrow, then choose =.

7. Click the first cell in the Right Value field and type 1.

8. Click OK.
The Tester Parameters dialog box closes.

Redefine the LOT_LINES destination feature

Redefine the LOT_LINES destination feature to generate the polygon features that failed the test clause
specified in the Tester transformer. Also, add a user attribute to capture the _overlay value.

Steps:

1. Connect the FAILED output on the Tester transformer to the INPUT on the LOT_LINES
destination feature.

2. Click the Properties button on the LOT_LINES destination feature.
The Feature Type Properties dialog box opens.
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3. Click the General tab.

4. In the Feature Type Name text box, type problem_polys.

5. Click the Allowed Geometries arrow and choose geodb_polyline.

6. Click the User Attributes tab.

7. Select all attributes and press DELETE.
The LOT_LINES attributes are not needed.

8. Click the first empty cell in the Attribute Name field and type num_points.
The num_points attribute is used to capture the _overlay attribute value generated by the
Tester transformer. This value represents the quantity of overlapping points for each failed
feature.

9. Click the Data Type arrow and choose integer.

10. Click OK.
The Feature Type Properties dialog box closes.

11. Expand the Tester transformer and connect the _overlay output to num_points on the
LOT_LINES destination feature.
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Redefine the LOT_POINTS destination feature

Redefine the LOT_POINTS destination feature to generate the polygon features that passed the test clause
specified in the Tester transformer.

Steps:

1. Connect the PASSED output on the Tester transformer to the INPUT on the LOT_POINTS
destination feature.

2. Click the Properties button on the LOT_POINTS destination feature.
The Feature Type Properties dialog box opens.

3. Click the General tab.

4. In the Feature Type Name text box, type parcels.

5. Click the Allowed Geometries arrow and choose geodb_polyline.

6. Click the User Attributes tab.

7. Select only the attributes with names that start with igds_ and press DELETE.
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The igds_ attributes are symbolic names created by the FME reader to simplify the translation
of the IGDS source element types to FME feature types. There is no need to include them with
the destination features.

8. Click OK.
The Feature Type Properties dialog box closes.

Verify the output of your workspace with Visualizer

Visualizer is an in-memory viewer that enables you to inspect the output of your workspace without
generating data or possibly overwriting existing data.

Redirect the output of your workspace to Visualizer and verify your results.

Steps:

1. In the Navigator window, expand Tool Settings, right-click Destination Redirect, then click
Edit Parameter from the shortcut menu.
The Edit Parameter dialog box opens.

2. Click the Destination Redirect arrow and choose Redirect to Visualizer.

3. Click OK.
The Edit Parameter dialog box closes.

4. On the main menu, click File > Run Translation.
Visualizer starts.
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5. Expand the datasets in Viewspace.

6. Click the Identify tool on the toolbar, select features, then explore their attribute values
displayed in the Information window.

Observe that the workspace creates polygons from line elements stored in the MicroStation
DGN (.par) files and acquires the point feature attributes stored in the parcels_attr.mdb
database. Also observe that the Tester transformer routed features that did not pass the test
clause to the problem_polys destination features.

7. Exit Visualizer.

8. On the Workbench menu, click File > Save.

Save the spatial ETL tool as a custom format

A custom format is a translation workspace that is exported as a format and utilized in the FME reader
gallery. It is saved to an external (.fds) file and can be imported to reader galleries on other desktops.

Creating a custom format adds the format to the FME reader gallery. Once created, subsequent uses of the
gallery allow you to edit the format in FME Workbench or delete it from the list and remove the (.fds) file
from the default folder location.

Steps:

1. On the Workbench menu, click File > Export as Custom Format.
The Set Custom Format Name and Description dialog box opens.

Data Interoperability Extension Tutorial

Copyright © 1995-2010 Esri. All rights reserved. 49



2. Type Custom_Parcels in the New Custom Format Name text box.

3. Type Custom Parcels in the New Custom Format Description text box.

4. Click OK.
A second Workbench session starts as a custom format (.fds) workspace.

5. Click File > Exit to close the custom format workspace.

6. Click File > Exit to close the transformation workspace.

This completes the exercise.

Continue to the next exercise: Exercise 3c: Using attribute values to control output.
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Exercise 3c: Using source attributes to separate data
This exercise introduces two methods for separating data based on attribute
values. They can be used to create spatial ETL tools that categorize source
data and generate sets of features with common values.

The first method separates the data within the workspace using the
ValueMapper transformer as a lookup table and routes the data to specific
AutoCAD block definitions. The second method separates the data at the
time of writing using the Fanout By Attribute writer parameter for a GML
dataset and generates unique feature types on the fly.

Using Workbench, you perform the following tasks:
• Add a ValueMapper transformer and map specific attribute values in the COVER field to AutoCAD

block definitions stored in the AutoCAD template (.dwg) file.

• Expose the AutoCAD properties for the block name, block rotation, and the block reference (insert)
entity.

• Specify the AutoCAD template file that is included with the tutorial data.

• Add a second data destination for a GML dataset and set the Fanout By Attribute parameter for each
unique value in the COVER field.

Create a toolbox and a spatial ETL tool

Prerequisite:
The Data Interoperability extension must be enabled.

Steps:

1. Start ArcMap.

2. Click the Catalog Window button on the Standard toolbar.

3. Type C:\arcgis\ArcTutor\Data Interoperability\birds_eggs\ in the Location
text box and press ENTER.
The location is added to the Catalog tree under the Folders Connection heading.

4. Right-click the birds_eggs folder and click New > Toolbox .

5. Right-click the toolbox, click Rename, then type nests.

6. Right-click the nests toolbox and click New > Spatial ETL Tool.

Complexity:
Advanced

Data Requirement:
ArcGIS Tutorial Data Setup

Data Path:
C:\arcgis\ArcTutor\Data Interoperability\

Goal:
Learn how to use source attribute values
in FME Workbench to separate data and
generate new features.
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Create Translation Workspace Wizard opens.

Create the translation workspace

Choosing the FME reader

Steps:

1. Click the Format button.
The FME Reader Gallery dialog box opens.

2. Type gdb in the Search text box.

3. Click the row listing the ESRI Geodatabase (Filed-based) format and click OK.
The FME Reader Gallery dialog box closes.

4. Click Next.
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Specifying the data source

Steps:

1. Click the Locate Source Data browse button.
The Select Geodatabase dialog box opens.

2. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\birds_eggs\
folder.

3. Click the nests.gdb folder and click Open.
The Select Geodatabase dialog box closes.

4. Click Next.

Specifying the reader parameters

Accept the default parameters for the geodatabase.

Steps:

1. Click Next.
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Choosing the FME writer

Steps:

1. Click the Format browse button.
The FME Writer Gallery dialog box opens.

2. Type dwg in the Search text box.

3. Click the row listing ESRI Geodatabase (File-based) and click OK.
The FME Writer Gallery dialog box closes.

4. Click Next.

Specifying the writer parameters

Accept the default parameters for the AutoCAD DWG format.

Steps:

1. Click Next.
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Creating the workspace

Steps:

1. Click Finish.
The wizard processes the information and starts Workbench.

2. Expand the source dataset NESTS and the destination feature NESTS. Observe that the
source feature attributes are mapped directly to the destination AutoCAD dataset.

Add a ValueMapper transformer

The ValueMapper transformer acts as a lookup table for input values and stores the output values in a user-
defined attribute.

Map the unique values in the COVER feature attribute field to specific AutoCAD block names stored in the
block_name attribute field.

Steps:

1. In the Transformers window, type valuem in the search text box and press ENTER.

2. Double-click ValueMapper.
A ValueMapper transformer is added to the canvas.

3. Right-click the ValueMapper transformer and click Insert Before from the shortcut menu.
Workbench Wizard starts.
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4. Click Next.
The transformer is connected to the source and destination datasets.

5. Click the Properties button on the ValueMapper transformer window.
The Edit ValueMapper Parameters dialog box opens.

6. Click the Source Attribute arrow and choose the Cover attribute.
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7. In the New Attribute Name text box, type block_name.
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Importing unique values

You can type the source input values manually or use the import wizard. You can use the import wizard
even when the destination values are unavailable. In this case, select the same source attributes for both
sides of the equation to generate a basic 1:1 mapping, then edit the destination values to match the
corresponding AutoCAD block names stored in the template (.dwg) file.

Steps:

1. Click Import.
Workbench Wizard starts.

2. Confirm the path is set to C:\arcgis\ArcTutor\Data Interoperability\birds_eggs\nests.gdb.

3. Click Next.

4. Click the feature type NEST and click Next.

5. Click the key attribute COVER and click Next.

6. Click the value attribute COVER and click Next.

7. Click Finish.

8. In the Default Value text box, type LOVSK.
During execution, the default value is used if the tool encounters an attribute value not listed
in the ValueMapper lookup table. In this exercise, you are providing a default AutoCAD
block name.

9. Double-click each value in the right-hand column and replace it with the corresponding
AutoCAD block name listed in the following table.

COVER attribute value block_name attribute value

rock KRYSS
willow BARRTR
conifer STOMPKT
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bare LOVTR

10. Click OK.
The Edit ValueMapper Parameters dialog box closes.

Expose the AutoCAD block properties

Exposing the AutoCAD block properties in the destination feature type enables you to control how the block
references are inserted in the destination AutoCAD (.dwg) file.

Steps:

1. Click the Properties button on the destination feature type NESTS.
The Feature Type Properties dialog box opens.

2. Click the Format Attributes tab.

3. Check the boxes for autocad_block_name, autocad_entity, and autocad_rotation.

4. Click OK.
The Feature Type Properties dialog box closes.

Connect input for the exposed format attributes

Steps:

1. Expand the attributes list for the ValueMapper transformer and the NESTS destination feature.
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Pan to the bottom of the lists and make the following connections:

2. Connect the ROTATION attribute to the autocad_rotation format attribute.
The rotation values are passed from the source data.

3. Connect the block_name attribute to the autocad_block_name format attribute.
The block_name values are generated by the ValueMapper lookup table.

4. Double-click the autocad_entity input (red) arrow.
New Constant appears as input.

5. Double-click New Constant and type autocad_insert.
The autocad_insert constant instructs FME Writer to insert a block reference for each output
entity. In addition to the graphic elements defined in the AutoCAD template (.dwg) file, the user
attributes specified for the destination dataset are written as block attributes to each block
reference.

Specify the AutoCAD template file

The AutoCAD template file contains the block definitions you specified in the ValueMapper lookup table.

Steps:

1. In the Navigator window, expand the destination format Parameters, right-click Template
File, then click Edit Parameter from the shortcut menu.
The Edit Parameter dialog box opens.
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2. Click the browse (...) button.
The Select Template File dialog box opens.

3. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\birds_eggs folder, click template.dwg,
then click Open.

4. Click OK.

5. Save your work and exit Workbench.

Save and rename the tool

Steps:

1. Click File > Save to save the tool.

2. Click File > Exit to exit Workbench.

3. Right-click the new spatial ETL tool in the Catalog window, click Rename, then type Nests
to AutoCAD.

Open and run the tool

Steps:

1. In the Catalog window, expand the Nests toolbox .

2. Double-click the Nests to AutoCAD tool.
The Nests to AutoCAD dialog box opens.
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3. Click OK.
The tool executes the conversion in the background. A progress bar at the bottom of your map
displays the name of the tool. When the tool is finished, a pop-up notification appears in the
system tray. You can examine the details of the conversion in the Results window.

Add the data to ArcMap

Steps:

1. In the Catalog window, expand the nests DWG dataset and drag the point feature class into
ArcMap to confirm your results.

Copy and rename the tool

Steps:
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1. In the Catalog window, right-click the Nests to AutoCAD tool and click Copy on the shortcut
menu.

2. Right-click the Nests toolbox and click Paste on the shortcut menu.

3. Right-click the Nests to AutoCAD (2) tool, click Rename on the shortcut menu, then type
Nests to AutoCAD and GML.

4. Right-click the Nests to AutoCAD and GML tool and click Edit.
Workbench starts.

Add a writer for GML

Add a writer and connect a second destination dataset for GML to the ValueMapper transformer OUTPUT.

Steps:

1. On the main menu, click Writers > Add Writer.
The Add Writer dialog box opens.

2. Click the Format browse button and choose Geography Markup Language (GML) from FME
Writer Gallery.

3. Click the Dataset browse button.
The Select File dialog box opens.

4. Navigate to the C:\arcgis\ArcTutor\Data Interoperability\birds_eggs\ folder, type nests in the
File name text box, then click Save.

5. Click OK.
Workbench prompts you to create a new feature type.

6. Click No.

Instead of creating a feature type from scratch, copy the AutoCAD feature type and edit the
settings.

7. Right-click the AutoCAD output feature type NESTS and click Duplicate from the shortcut
menu.

8. Connect the ValueMapper OUTPUT to the INPUT of the new destination feature type.
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9. Click the Properties button on the destination feature type NESTS.
The Feature Type Properties dialog box opens.

10. In the Feature Type Name text box, type NESTS_gml.

11. Check the Fanout By Attribute check box, click the arrow, then choose COVER.
The Fanout setting generates a new output feature type on the fly for each unique value in the
COVER attribute field.

12. Click the Dataset arrow and choose nests [GML].

13. Click OK.
The Feature Type Properties dialog box closes.

Save and run the tool

Steps:

1. Click File > Save to save the tool.

2. Click File > Exit to exit Workbench.

3. In the Catalog window, expand the Nests toolbox .

4. Double-click the Nests to AutoCAD tool.
The Nests to AutoCAD dialog box opens.
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5. Click OK.
The tool executes the conversion in the background. A progress bar at the bottom of your map
displays the name of the tool. When the tool is finished, a pop-up notification appears in the
system tray. You can examine the details of the conversion in the Results window.

Add the data to ArcMap

Steps:

1. In the Catalog window, drag the nests GML dataset into ArcMap to verify your results.

This completes the exercise.
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