What's new in ArcMap 10 basics

Updated icons and pull-down menus

In ArcGIS 10, all the icons have been re-created to take advantage of more colors and make them more attractive. The symbols used in the icons are the same, though, so you'll still be able to recognize them.

The pull-down menus are generally the same, so you don't have to relearn your workflows when you migrate to ArcGIS 10. There are some small changes that have been made:

Easy to access great-looking basemaps for your map

The Add Data button on the Standard toolbar is now a menu button that includes two new commands for adding online content to your map:

Add data menu button

The Add Basemap command lets you choose an online basemap for your map. The gallery of basemaps includes the key ArcGIS Online basemaps, such as World Imagery, World Streets, and the World Topographic Map, as well as the Bing Maps services. These basemaps all require an Internet connection for them to draw in your map. This makes it quick and easy to immediately add great basemaps to your own map without having to download or manage the data locally. The content in these services is frequently updated, too:

Add Basemap dialog box


If you have not upgraded to ArcGIS 10 yet, don't forget that you can access these basemaps and use them in your current version of the software. In 9.3, launch the File > Add Data From Resource Center command. In 9.3.1, launch the File > Add Data > Add Data From ArcGIS Online command .

New dockable window controls make it easy to arrange and organize your display

With ArcGIS 10, you can arrange the windows in your map display any way you want so you can see more of your map and reduce clutter. Dockable windows, such as the table of contents, the ArcToolbox window, the new Catalog window, and the new Search window, are easier to work with.

A new pin control on every dockable window lets you unpin it to autohide it. An autohidden window is shown as a tab in the display, which you can pause over or click to make the window expand whenever you want to use it. After you expand an autohidden window, it will automatically hide itself again when you click somewhere else, such as choosing a tool from a toolbar, or click on the map display. At any time, you can click the pin control again to dock the window so it remains in place.

Hiding a dockable window

To move a docked window to a new location, drag its title bar. When you do this, blue targets appear representing the different locations where the window can be docked. Drop the window onto the target of your choice. Pause over a target to get a preview of where the window will be located if you drop it on that target. If you want the window to float over the display instead of being docked, don't drop it onto one of the blue targets.

Relocating a dockable window

In addition to being able to dock a window to the left or right or above or below another docked window, you can also stack windows on top of each other so they appear as tabs. This is a convenient way to work with multiple dockable windows. Simply drag one dockable window over another, and you'll see an extra target appear that enables you to stack them together. In the graphic example below, the Catalog window is being stacked with the Table Of Contents window:

Stacking a dockable window with another

You can double-click the title bar of a window to quickly toggle it between docked and undocked. If you've stacked two or more windows together, you can also double-click the tabs with which they are shown to toggle between their being docked and undocked. This is useful, for example, if you normally work with a particular window docked but want to quickly pop it out to be a larger, floating window.

More windows are now dockable

GIS is about working with maps and their attributes together. ArcGIS 10 allows you to dock windows that show the attributes of your layers next to your map so that they don't cover up your map. Table windows, the Identify window, and the Attributes window (launched from the Editor toolbar) are now dockable. If you open multiple tables, they are all automatically displayed inside the same Table window, making it easier to manage them together in your display. Each table is shown as a tab at the bottom of the Table window, and you can also drag and drop these tabs so you can view the tables side by side.

Learn more about working with tables in ArcGIS 10

Table of contents

In ArcGIS 10, the table of contents has been enhanced to add two additional views for working with your data. These two new views are in addition to the existing display and source views. You choose the table of contents view you want to work with using the new buttons at the top of the Table Of Contents window instead of tabs at the bottom of the window, like in previous versions.

Table of contents view button

Learn more about working with the table of contents in ArcGIS 10